# CVE-2018-1000600: CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials

> Attackers can capture Jenkins-stored credentials by directing the plugin to an attacker-controlled URL using specific credential IDs.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-6cvm-v6qj-hjq9

## What is CVE-2018-1000600?

CVE-2018-1000600 is a high-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

A exposure of sensitive information vulnerability exists in Jenkins GitHub Plugin 1.29.1 and earlier in GitHubTokenCredentialsCreator.java that allows attackers to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1000600?

2 open source packages ship an affected version, including com.coravy.hudson.plugins.github:github. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.29.2 |
| `com.coravy.hudson.plugins.github:github` | Maven | All versions | 1.29.2 |

Products: Jenkins Github.

## How do I fix CVE-2018-1000600?

Upgrade com.coravy.hudson.plugins.github:github to 1.29.2 or later.

## Is CVE-2018-1000600 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000600 exists.

Public exploit code:

- Jenkins GitHub Plugin <=1.29.1 - Server-Side Request Forgery (nuclei): http/cves/2018/CVE-2018-1000600.yaml

## Other vulnerabilities in n/a

- [CVE-2026-42523](https://insights.sbomify.com/CVE-2026-42523/): Jenkins GitHub Plugin has an XSS vulnerability (critical 9.0)
- [CVE-2018-1000183](https://insights.sbomify.com/CVE-2018-1000183/): Jenkins GitHub Plugin exposure of sensitive information vulnerability exists (medium 6.5)
- [CVE-2023-46650](https://insights.sbomify.com/CVE-2023-46650/): Stored XSS vulnerability in Jenkins GitHub Plugin (medium 5.4)
- [CVE-2018-1000184](https://insights.sbomify.com/CVE-2018-1000184/): Jenkins GitHub Plugin server-side request forgery vulnerability exists (medium 5.4)
- [CVE-2022-36885](https://insights.sbomify.com/CVE-2022-36885/): Jenkins GitHub plugin uses weak webhook signature function (medium 5.3)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000600 and fix it if it is affected.

What it is: CVE-2018-1000600 is a high-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-1000600 exists.

Affected packages and fixed versions:
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.2
- com.coravy.hudson.plugins.github:github (Maven): affected all versions; fixed in 1.29.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000600/ (Markdown: https://insights.sbomify.com/CVE-2018-1000600/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000600
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000600
- OSV: https://osv.dev/vulnerability/CVE-2018-1000600

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000600/
Summaries are generated and may contain mistakes; the official description above is the record.
