{"answers":{"affected":"4 open source packages ship an affected version, including org.jenkins-ci.plugins:credentials and org.jenkins-ci.plugins:ssh-credentials. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000601 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:credentials to 2.1.17 or later.","what":"CVE-2018-1000601 is a medium-severity path traversal vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000601 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000601 is a medium-severity path traversal vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000601 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:credentials (Maven): affected all versions; fixed in 2.1.17\n- org.jenkins-ci.plugins:credentials (Maven): affected all versions; fixed in 2.1.17\n- org.jenkins-ci.plugins:ssh-credentials (Maven): affected all versions; fixed in 1.14\n- org.jenkins-ci.plugins:ssh-credentials (Maven): affected all versions; fixed in 1.14\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000601/ (Markdown: https://insights.sbomify.com/CVE-2018-1000601/index.md)","id":"CVE-2018-1000601","markdown":"https://insights.sbomify.com/CVE-2018-1000601/index.md","name":"CVE-2018-1000601","record":{"aliases":["GHSA-cwcf-5m5w-mq2w"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins SSH Credentials Plugin","requires_auth":"low_privilege","summary":"Attackers with specific Jenkins permissions can read arbitrary files from the master file system via the SSH Credentials Plugin.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ssh_credentials","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:N","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A arbitrary file read vulnerability exists in Jenkins SSH Credentials Plugin 1.13 and earlier in BasicSSHUserPrivateKey.java that allows attackers with a Jenkins account and the permission to configure credential bindings to read arbitrary files from the Jenkins master file system.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Exposure of Sensitive Information to an Unauthorized Actor in Jenkins SSH Credentials Plugin","id":"CVE-2018-1000601","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":4,"n_references":1,"next":{"headline":"Jenkins SAML Plugin Session Fixation vulnerability","id":"CVE-2018-1000602"},"packages":[{"ecosystem":"Maven","fixed":["2.1.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:credentials","purl":null,"source":"GHSA-cwcf-5m5w-mq2w"},{"ecosystem":"Maven","fixed":["2.1.17"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:credentials","purl":"pkg:maven/org.jenkins-ci.plugins/credentials","source":"GHSA-cwcf-5m5w-mq2w"},{"ecosystem":"Maven","fixed":["1.14"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ssh-credentials","purl":null,"source":"GHSA-cwcf-5m5w-mq2w"},{"ecosystem":"Maven","fixed":["1.14"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:ssh-credentials","purl":"pkg:maven/org.jenkins-ci.plugins/ssh-credentials","source":"GHSA-cwcf-5m5w-mq2w"}],"prev":{"headline":"CSRF vulnerability and missing permission checks in GitHub Plugin allowed capturing credentials","id":"CVE-2018-1000600"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers with specific Jenkins permissions can read arbitrary files from the master file system via the SSH Credentials Plugin.","url":"https://insights.sbomify.com/CVE-2018-1000601/"}