# CVE-2018-1000602: Jenkins SAML Plugin Session Fixation vulnerability

> Attackers can impersonate users via session fixation in the Jenkins SAML Plugin if they control the pre-authentication session.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-4pjx-86pg-x4j5

## What is CVE-2018-1000602?

CVE-2018-1000602 is a medium-severity authentication bypass vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A session fixation vulnerability exists in Jenkins SAML Plugin 1.0.6 and earlier in SamlSecurityRealm.java that allows unauthorized attackers to impersonate another users if they can control the pre-authentication session.

Weakness: CWE-384 (Session Fixation)

## Which versions are affected by CVE-2018-1000602?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:saml. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:saml` | Maven | All versions | 1.0.7 |
| `org.jenkins-ci.plugins:saml` | Maven | All versions | 1.0.7 |

Products: Jenkins Saml.

## How do I fix CVE-2018-1000602?

Upgrade org.jenkins-ci.plugins:saml to 1.0.7 or later.

## Is CVE-2018-1000602 being exploited?

There is no known exploitation of CVE-2018-1000602 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2021-21678](https://insights.sbomify.com/CVE-2021-21678/): Jenkins SAML Plugin allows bypassing CSRF protection for any URL (high 8.8)
- [CVE-2025-64131](https://insights.sbomify.com/CVE-2025-64131/): Jenkins SAML Plugin does not implement a replay cache (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000602 and fix it if it is affected.

What it is: CVE-2018-1000602 is a medium-severity authentication bypass vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000602 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:saml (Maven): affected all versions; fixed in 1.0.7
- org.jenkins-ci.plugins:saml (Maven): affected all versions; fixed in 1.0.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000602/ (Markdown: https://insights.sbomify.com/CVE-2018-1000602/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000602
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000602
- OSV: https://osv.dev/vulnerability/CVE-2018-1000602

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000602/
Summaries are generated and may contain mistakes; the official description above is the record.
