{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:openstack-cloud. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000603 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:openstack-cloud to 2.37 or later.","what":"CVE-2018-1000603 is a high-severity server-side request forgery vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000603 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000603 is a high-severity server-side request forgery vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000603 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:openstack-cloud (Maven): affected all versions; fixed in 2.37\n- org.jenkins-ci.plugins:openstack-cloud (Maven): affected all versions; fixed in 2.37\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000603/ (Markdown: https://insights.sbomify.com/CVE-2018-1000603/index.md)","id":"CVE-2018-1000603","markdown":"https://insights.sbomify.com/CVE-2018-1000603/index.md","name":"CVE-2018-1000603","record":{"aliases":["GHSA-grf8-94q5-4phx"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["data_read","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Openstack Cloud Plugin","requires_auth":"low_privilege","summary":"Attackers with read access can force Jenkins to make requests to attacker-controlled URLs, potentially capturing stored credentials.","user_interaction":"not_required","vuln_class":"ssrf"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"openstack_cloud","vendor":"jenkins"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-200","name":"Exposure of Sensitive Information to an Unauthorized Actor"}],"description":"A exposure of sensitive information vulnerability exists in Jenkins Openstack Cloud Plugin 2.35 and earlier in BootSource.java, InstancesToRun.java, JCloudsCleanupThread.java, JCloudsCloud.java, JCloudsComputer.java, JCloudsPreCreationThread.java, JCloudsRetentionStrategy.java, JCloudsSlave.java, JCloudsSlaveTemplate.java, LauncherFactory.java, OpenstackCredentials.java, OpenStackMachineStep.java, SlaveOptions.java, SlaveOptionsDescriptor.java that allows attackers with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins, and to cause Jenkins to submit HTTP requests to attacker-specified URLs.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CSRF vulnerability and missing permission checks in Openstack Cloud Plugin allowed capturing credentials","id":"CVE-2018-1000603","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"ssrf","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins Badge Plugin cross-site scripting vulnerability","id":"CVE-2018-1000604"},"packages":[{"ecosystem":"Maven","fixed":["2.37"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:openstack-cloud","purl":null,"source":"GHSA-grf8-94q5-4phx"},{"ecosystem":"Maven","fixed":["2.37"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:openstack-cloud","purl":"pkg:maven/org.jenkins-ci.plugins/openstack-cloud","source":"GHSA-grf8-94q5-4phx"}],"prev":{"headline":"Jenkins SAML Plugin Session Fixation vulnerability","id":"CVE-2018-1000602"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers with read access can force Jenkins to make requests to attacker-controlled URLs, potentially capturing stored credentials.","url":"https://insights.sbomify.com/CVE-2018-1000603/"}