# CVE-2018-1000603: CSRF vulnerability and missing permission checks in Openstack Cloud Plugin allowed capturing credentials

> Attackers with read access can force Jenkins to make requests to attacker-controlled URLs, potentially capturing stored credentials.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-grf8-94q5-4phx

## What is CVE-2018-1000603?

CVE-2018-1000603 is a high-severity server-side request forgery vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A exposure of sensitive information vulnerability exists in Jenkins Openstack Cloud Plugin 2.35 and earlier in BootSource.java, InstancesToRun.java, JCloudsCleanupThread.java, JCloudsCloud.java, JCloudsComputer.java, JCloudsPreCreationThread.java, JCloudsRetentionStrategy.java, JCloudsSlave.java, JCloudsSlaveTemplate.java, LauncherFactory.java, OpenstackCredentials.java, OpenStackMachineStep.java, SlaveOptions.java, SlaveOptionsDescriptor.java that allows attackers with Overall/Read access to Jenkins to connect to an attacker-specified URL using attacker-specified credentials IDs obtained through another method, capturing credentials stored in Jenkins, and to cause Jenkins to submit HTTP requests to attacker-specified URLs.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2018-1000603?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:openstack-cloud. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:openstack-cloud` | Maven | All versions | 2.37 |
| `org.jenkins-ci.plugins:openstack-cloud` | Maven | All versions | 2.37 |

Products: Jenkins Openstack Cloud.

## How do I fix CVE-2018-1000603?

Upgrade org.jenkins-ci.plugins:openstack-cloud to 2.37 or later.

## Is CVE-2018-1000603 being exploited?

There is no known exploitation of CVE-2018-1000603 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000603 and fix it if it is affected.

What it is: CVE-2018-1000603 is a high-severity server-side request forgery vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000603 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:openstack-cloud (Maven): affected all versions; fixed in 2.37
- org.jenkins-ci.plugins:openstack-cloud (Maven): affected all versions; fixed in 2.37

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000603/ (Markdown: https://insights.sbomify.com/CVE-2018-1000603/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000603
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000603
- OSV: https://osv.dev/vulnerability/CVE-2018-1000603

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000603/
Summaries are generated and may contain mistakes; the official description above is the record.
