{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:collabnet. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000605 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:collabnet to 2.0.5 or later.","what":"CVE-2018-1000605 is a high-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000605 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000605 is a high-severity vulnerability in n/a, published on 26 Jun 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000605 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:collabnet (Maven): affected all versions; fixed in 2.0.5\n- org.jenkins-ci.plugins:collabnet (Maven): affected all versions; fixed in 2.0.5\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000605/ (Markdown: https://insights.sbomify.com/CVE-2018-1000605/index.md)","id":"CVE-2018-1000605","markdown":"https://insights.sbomify.com/CVE-2018-1000605/index.md","name":"CVE-2018-1000605","record":{"aliases":["GHSA-m8x2-4gc8-9v3r"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass","data_read"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins CollabNet Plugin","requires_auth":"none","summary":"A man-in-the-middle vulnerability in the Jenkins CollabNet Plugin allows attackers to impersonate connected services, compromising data integrity and confidentiality.","user_interaction":"not_required","vuln_class":"other"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"collabnet","vendor":"jenkins"}],"cvss":{"score":7.4,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-295","name":"Improper Certificate Validation"}],"description":"A man in the middle vulnerability exists in Jenkins CollabNet Plugin 2.0.4 and earlier in CollabNetApp.java, CollabNetPlugin.java, CNFormFieldValidator.java that allows attackers to impersonate any service that Jenkins connects to.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Jenkins CollabNet Plugin man in the middle vulnerability","id":"CVE-2018-1000605","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"other","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"URLTrigger Plugin server-side request forgery vulnerability","id":"CVE-2018-1000606"},"packages":[{"ecosystem":"Maven","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:collabnet","purl":null,"source":"GHSA-m8x2-4gc8-9v3r"},{"ecosystem":"Maven","fixed":["2.0.5"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:collabnet","purl":"pkg:maven/org.jenkins-ci.plugins/collabnet","source":"GHSA-m8x2-4gc8-9v3r"}],"prev":{"headline":"Jenkins Badge Plugin cross-site scripting vulnerability","id":"CVE-2018-1000604"},"products":["n/a"],"published":"2018-06-26","related":[{"cvss_score":6.5,"headline":"RabbitMQ password stored in plain text by Jenkins CollabNet Plugins Plugin","id":"CVE-2022-38665","kev_date_added":null,"published":"2022-08-23"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"A man-in-the-middle vulnerability in the Jenkins CollabNet Plugin allows attackers to impersonate connected services, compromising data integrity and confidentiality.","url":"https://insights.sbomify.com/CVE-2018-1000605/"}