{"answers":{"affected":"2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000607 in the wild and no public exploit code.","fix":"Upgrade org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin to 1.5.2 or later.","what":"CVE-2018-1000607 is a medium-severity path traversal vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000607 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000607 is a medium-severity path traversal vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000607 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin (Maven): affected all versions; fixed in 1.5.2\n- org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin (Maven): affected all versions; fixed in 1.5.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000607/ (Markdown: https://insights.sbomify.com/CVE-2018-1000607/index.md)","id":"CVE-2018-1000607","markdown":"https://insights.sbomify.com/CVE-2018-1000607/index.md","name":"CVE-2018-1000607","record":{"aliases":["GHSA-8864-pwhg-3mp2"],"analysis":{"component_type":"cms_plugin","fix_type":"upgrade","impacts":["data_modify","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Jenkins Fortify Plugin","requires_auth":"low_privilege","summary":"Attackers controlling rulepack zip contents can overwrite arbitrary files on the Jenkins master, potentially leading to code execution.","user_interaction":"not_required","vuln_class":"path_traversal"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"fortify_cloudscan","vendor":"jenkins"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"A arbitrary file write vulnerability exists in Jenkins Fortify CloudScan Plugin 1.5.1 and earlier in ArchiveUtil.java that allows attackers able to control rulepack zip file contents to overwrite any file on the Jenkins master file system, only limited by the permissions of the user the Jenkins master process is running as.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Arbitrary file write vulnerability in Jenkins Fortify CloudScan Plugin","id":"CVE-2018-1000607","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":null,"products":[],"type":"path_traversal","year":"2018"},"n_packages":2,"n_references":1,"next":{"headline":"Jenkins z/OS Connector Plugin allows local attacker to retrieve configured password","id":"CVE-2018-1000608"},"packages":[{"ecosystem":"Maven","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin","purl":null,"source":"GHSA-8864-pwhg-3mp2"},{"ecosystem":"Maven","fixed":["1.5.2"],"introduced":["0"],"last_affected":[],"package":"org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin","purl":"pkg:maven/org.jenkins-ci.plugins/fortify-cloudscan-jenkins-plugin","source":"GHSA-8864-pwhg-3mp2"}],"prev":{"headline":"URLTrigger Plugin server-side request forgery vulnerability","id":"CVE-2018-1000606"},"products":["n/a"],"published":"2018-06-26","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Attackers controlling rulepack zip contents can overwrite arbitrary files on the Jenkins master, potentially leading to code execution.","url":"https://insights.sbomify.com/CVE-2018-1000607/"}