# CVE-2018-1000607: Arbitrary file write vulnerability in Jenkins Fortify CloudScan Plugin

> Attackers controlling rulepack zip contents can overwrite arbitrary files on the Jenkins master, potentially leading to code execution.

- **Severity:** Medium 6.5 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 26 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-8864-pwhg-3mp2

## What is CVE-2018-1000607?

CVE-2018-1000607 is a medium-severity path traversal vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A arbitrary file write vulnerability exists in Jenkins Fortify CloudScan Plugin 1.5.1 and earlier in ArchiveUtil.java that allows attackers able to control rulepack zip file contents to overwrite any file on the Jenkins master file system, only limited by the permissions of the user the Jenkins master process is running as.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1000607?

2 open source packages ship an affected version, including org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin` | Maven | All versions | 1.5.2 |
| `org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin` | Maven | All versions | 1.5.2 |

Products: Jenkins Fortify Cloudscan.

## How do I fix CVE-2018-1000607?

Upgrade org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin to 1.5.2 or later.

## Is CVE-2018-1000607 being exploited?

There is no known exploitation of CVE-2018-1000607 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000607 and fix it if it is affected.

What it is: CVE-2018-1000607 is a medium-severity path traversal vulnerability in n/a, published on 26 Jun 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000607 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin (Maven): affected all versions; fixed in 1.5.2
- org.jenkins-ci.plugins:fortify-cloudscan-jenkins-plugin (Maven): affected all versions; fixed in 1.5.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000607/ (Markdown: https://insights.sbomify.com/CVE-2018-1000607/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000607
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000607
- OSV: https://osv.dev/vulnerability/CVE-2018-1000607

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000607/
Summaries are generated and may contain mistakes; the official description above is the record.
