{"answers":{"affected":"4 open source packages ship an affected version, including cryptiles. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000620 in the wild and no public exploit code.","fix":"Upgrade cryptiles to a fixed version for your release line: 3.1.3 or 4.1.2.","what":"CVE-2018-1000620 is a critical vulnerability in n/a, published on 9 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000620 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000620 is a critical vulnerability in n/a, published on 9 Jul 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000620 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- cryptiles (npm): affected from 3.1.0; fixed in 3.1.3\n- cryptiles (npm): affected from 3.1.0; fixed in 3.1.3\n- cryptiles (npm): affected from 4.0.0; fixed in 4.1.2\n- cryptiles (npm): affected from 4.0.0; fixed in 4.1.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000620/ (Markdown: https://insights.sbomify.com/CVE-2018-1000620/index.md)","id":"CVE-2018-1000620","markdown":"https://insights.sbomify.com/CVE-2018-1000620/index.md","name":"CVE-2018-1000620","record":{"aliases":["GHSA-rq8g-5pc5-wrhr"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Node.js random library","requires_auth":"none","summary":"Insufficient entropy in randomDigits allows attackers to brute force values intended to be random, affecting applications using the cryptiles library.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"cryptiles","vendor":"cryptiles_project"}],"cvss":{"score":9.8,"severity":"critical","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-331","name":"Insufficient Entropy"}],"description":"Eran Hammer cryptiles version 4.1.1 earlier contains a CWE-331: Insufficient Entropy vulnerability in randomDigits() method that can result in An attacker is more likely to be able to brute force something that was supposed to be random.. This attack appear to be exploitable via Depends upon the calling application.. This vulnerability appears to have been fixed in 4.1.2.","ecosystems":["npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Insufficient Entropy in cryptiles","id":"CVE-2018-1000620","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"npm","product":null,"products":[],"type":"weak_cryptography","year":"2018"},"n_packages":4,"n_references":2,"next":{"headline":"Missing authorization in n/a","id":"CVE-2018-1000621"},"packages":[{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["3.1.0"],"last_affected":[],"package":"cryptiles","purl":null,"source":"GHSA-rq8g-5pc5-wrhr"},{"ecosystem":"npm","fixed":["3.1.3"],"introduced":["3.1.0"],"last_affected":[],"package":"cryptiles","purl":"pkg:npm/cryptiles","source":"GHSA-rq8g-5pc5-wrhr"},{"ecosystem":"npm","fixed":["4.1.2"],"introduced":["4.0.0"],"last_affected":[],"package":"cryptiles","purl":null,"source":"GHSA-rq8g-5pc5-wrhr"},{"ecosystem":"npm","fixed":["4.1.2"],"introduced":["4.0.0"],"last_affected":[],"package":"cryptiles","purl":"pkg:npm/cryptiles","source":"GHSA-rq8g-5pc5-wrhr"}],"prev":{"headline":"File upload in n/a","id":"CVE-2018-1000619"},"products":["n/a"],"published":"2018-07-09","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Insufficient entropy in randomDigits allows attackers to brute force values intended to be random, affecting applications using the cryptiles library.","url":"https://insights.sbomify.com/CVE-2018-1000620/"}