CVE-2018-1000632 Dom4j contains a XML Injection vulnerability
An attacker can tamper with XML documents via injection in dom4j, potentially modifying data structures.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1000632?
CVE-2018-1000632 is a high-severity vulnerability in Debian Debian Linux, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
dom4j version prior to version 2.1.1 contains a CWE-91: XML Injection vulnerability in Class: Element. Methods: addElement, addAttribute that can result in an attacker tampering with XML documents through XML injection. This attack appear to be exploitable via an attacker specifying attributes or elements in the XML document. This vulnerability appears to have been fixed in 2.1.1 or later.
Weakness: CWE-91
Which versions are affected by CVE-2018-1000632?
6 open source packages ship an affected version, including org.dom4j:dom4j and dom4j:dom4j. It affects 14 products.
| Package | Affected | Fixed in |
|---|---|---|
org.dom4j:dom4j Maven | All versions | 2.0.3 |
org.dom4j:dom4j Maven | All versions | 2.0.3 |
org.dom4j:dom4j Maven | From 2.1.0 | 2.1.1 |
org.dom4j:dom4j Maven | From 2.1.0 | 2.1.1 |
dom4j:dom4j Maven | All versions to 1.6.1 | None |
dom4j:dom4j Maven | All versions to 1.6.1 | None |
Linux distribution packages (5)
dom4j SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 1.6.1-8.3.8.1 |
dom4j SUSE:Manager Server 3.0 | All versions | 1.6.1-27.4.1 |
dom4j SUSE:Manager Server 3.1 | All versions | 1.6.1-3.3.2 |
dom4j SUSE:Manager Server 3.2 | All versions | 1.6.1-27.4.1 |
dom4j SUSE:Package Hub 15 | All versions | 1.6.1-bp150.2.3.1 |
Products include Debian Debian Linux, Dom4j Project Dom4j, Netapp Oncommand Workflow Automation, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager and 8 more.
How do I fix CVE-2018-1000632?
Upgrade org.dom4j:dom4j to a fixed version for your release line: 2.0.3 or 2.1.1.
Is CVE-2018-1000632 being exploited?
There is no known exploitation of CVE-2018-1000632 in the wild and no public exploit code.
Other vulnerabilities in Debian Debian Linux
Sources
Also known as DEBIAN-CVE-2018-1000632, DLA-1517-1, GHSA-6pcc-3rfx-4gpm, MGASA-2019-0077, ROOT-APP-MAVEN-CVE-2018-1000632, SUSE-SU-2018:2861-1 and 5 more.