# CVE-2018-1000632: Dom4j contains a XML Injection vulnerability

> An attacker can tamper with XML documents via injection in dom4j, potentially modifying data structures.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000632, DLA-1517-1, GHSA-6pcc-3rfx-4gpm, MGASA-2019-0077, ROOT-APP-MAVEN-CVE-2018-1000632, SUSE-SU-2018:2861-1, SUSE-SU-2018:2863-1, SUSE-SU-2018:3424-1, UBUNTU-CVE-2018-1000632, USN-4619-1, openSUSE-SU-2018:4045-1

## What is CVE-2018-1000632?

CVE-2018-1000632 is a high-severity vulnerability in Debian Debian Linux, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

dom4j version prior to version 2.1.1 contains a CWE-91: XML Injection vulnerability in Class: Element. Methods: addElement, addAttribute that can result in an attacker tampering with XML documents through XML injection. This attack appear to be exploitable via an attacker specifying attributes or elements in the XML document. This vulnerability appears to have been fixed in 2.1.1 or later.

Weakness: CWE-91 (XML Injection)

## Which versions are affected by CVE-2018-1000632?

6 open source packages ship an affected version, including org.dom4j:dom4j and dom4j:dom4j. It affects 14 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.dom4j:dom4j` | Maven | All versions | 2.0.3 |
| `org.dom4j:dom4j` | Maven | All versions | 2.0.3 |
| `org.dom4j:dom4j` | Maven | From 2.1.0 | 2.1.1 |
| `org.dom4j:dom4j` | Maven | From 2.1.0 | 2.1.1 |
| `dom4j:dom4j` | Maven | All versions to 1.6.1 | None |
| `dom4j:dom4j` | Maven | All versions to 1.6.1 | None |
| `dom4j` | SUSE:Linux Enterprise Software Development Kit 11 SP4 | All versions | 1.6.1-8.3.8.1 |
| `dom4j` | SUSE:Manager Server 3.0 | All versions | 1.6.1-27.4.1 |
| `dom4j` | SUSE:Manager Server 3.1 | All versions | 1.6.1-3.3.2 |
| `dom4j` | SUSE:Manager Server 3.2 | All versions | 1.6.1-27.4.1 |
| `dom4j` | SUSE:Package Hub 15 | All versions | 1.6.1-bp150.2.3.1 |

Products: Debian Debian Linux, Dom4j Project Dom4j, Netapp Oncommand Workflow Automation, Netapp Snap Creator Framework, Netapp Snapcenter, Netapp Snapmanager, Oracle Flexcube Investor Servicing, Oracle Primavera P6 Enterprise Project Portfolio Management, Oracle Rapid Planning, Oracle Retail Integration Bus, Oracle Utilities Framework, Redhat Jboss Enterprise Application Platform, Redhat Satellite, Redhat Satellite Capsule.

## How do I fix CVE-2018-1000632?

Upgrade org.dom4j:dom4j to a fixed version for your release line: 2.0.3 or 2.1.1.

## Is CVE-2018-1000632 being exploited?

There is no known exploitation of CVE-2018-1000632 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000632 and fix it if it is affected.

What it is: CVE-2018-1000632 is a high-severity vulnerability in Debian Debian Linux, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000632 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.dom4j:dom4j (Maven): affected all versions; fixed in 2.0.3
- org.dom4j:dom4j (Maven): affected all versions; fixed in 2.0.3
- org.dom4j:dom4j (Maven): affected from 2.1.0; fixed in 2.1.1
- org.dom4j:dom4j (Maven): affected from 2.1.0; fixed in 2.1.1
- dom4j:dom4j (Maven): affected all versions up to 1.6.1; no fix listed
- dom4j:dom4j (Maven): affected all versions up to 1.6.1; no fix listed

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000632/ (Markdown: https://insights.sbomify.com/CVE-2018-1000632/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000632
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000632
- OSV: https://osv.dev/vulnerability/CVE-2018-1000632

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000632/
Summaries are generated and may contain mistakes; the official description above is the record.
