# CVE-2018-1000637: Memory corruption in n/a

> A buffer overflow in zutils allows attackers to execute arbitrary code or cause denial of service by tricking users into opening a crafted compressed file.

- **Severity:** High 7.8 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1000637, DLA-1505-1, GHSA-px98-fj37-9hmp, UBUNTU-CVE-2018-1000637

## What is CVE-2018-1000637?

CVE-2018-1000637 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 20 Aug 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

zutils version prior to version 1.8-pre2 contains a Buffer Overflow vulnerability in zcat that can result in Potential denial of service or arbitrary code execution. This attack appear to be exploitable via the victim openning a crafted compressed file. This vulnerability appears to have been fixed in 1.8-pre2.

Weakness: CWE-119 (Improper Restriction of Operations within the Bounds of a Memory Buffer)

## Which versions are affected by CVE-2018-1000637?

It affects 2 products.


Products: Debian Debian Linux, Nongnu Zutils.

## How do I fix CVE-2018-1000637?

Upgrade to a fixed version.

## Is CVE-2018-1000637 being exploited?

There is no known exploitation of CVE-2018-1000637 in the wild and no public exploit code.

## Other vulnerabilities in Debian Debian Linux

- [CVE-2015-3306](https://insights.sbomify.com/CVE-2015-3306/): ProFTPD Improper Access Control (critical 10.0, exploited in the wild)
- [CVE-2025-49113](https://insights.sbomify.com/CVE-2025-49113/): RoundCube Webmail Deserialization of Untrusted Data (critical 9.9, exploited in the wild)
- [CVE-2026-24061](https://insights.sbomify.com/CVE-2026-24061/): GNU InetUtils Argument Injection (critical 9.8, exploited in the wild)
- [CVE-2025-39682](https://insights.sbomify.com/CVE-2025-39682/): Linux Kernel Improper Check for Unusual or Exceptional Conditions (critical 9.8, exploited in the wild)
- [CVE-2024-9680](https://insights.sbomify.com/CVE-2024-9680/): Mozilla Firefox Use-After-Free (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000637 and fix it if it is affected.

What it is: CVE-2018-1000637 is a high-severity memory corruption vulnerability in Debian Debian Linux, published on 20 Aug 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000637 in the wild and no public exploit code.

Affected product: Debian Debian Linux. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000637/ (Markdown: https://insights.sbomify.com/CVE-2018-1000637/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000637
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000637
- OSV: https://osv.dev/vulnerability/CVE-2018-1000637

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000637/
Summaries are generated and may contain mistakes; the official description above is the record.
