# CVE-2018-1000644: Eclipse RDF4j vulnerable to XML External Entity

> Attackers can exploit an XML External Entity vulnerability in the RDF4j library to disclose confidential data or cause denial of service via crafted RDF files.

- **Severity:** Critical 10.0 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1000644, GHSA-6xq8-pvg4-3mf3

## What is CVE-2018-1000644?

CVE-2018-1000644 is a critical vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Eclipse RDF4j version < 2.4.0 Milestone 2 contains a XML External Entity (XXE) vulnerability in RDF4j XML parser parsing RDF files that can result in the disclosure of confidential data, denial of service, server side request forgery, port scanning. This attack appear to be exploitable via Specially crafted RDF file.

Weakness: CWE-611 (Improper Restriction of XML External Entity Reference)

## Which versions are affected by CVE-2018-1000644?

2 open source packages ship an affected version, including org.eclipse.rdf4j:rdf4j-runtime. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.eclipse.rdf4j:rdf4j-runtime` | Maven | All versions | 2.4.0 |
| `org.eclipse.rdf4j:rdf4j-runtime` | Maven | All versions | 2.4.0 |

Products: Eclipse Rdf4j.

## How do I fix CVE-2018-1000644?

Upgrade org.eclipse.rdf4j:rdf4j-runtime to 2.4.0 or later.

## Is CVE-2018-1000644 being exploited?

There is no known exploitation of CVE-2018-1000644 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-20227](https://insights.sbomify.com/CVE-2018-20227/): RDF4J vulnerable to zip slip (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000644 and fix it if it is affected.

What it is: CVE-2018-1000644 is a critical vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000644 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.eclipse.rdf4j:rdf4j-runtime (Maven): affected all versions; fixed in 2.4.0
- org.eclipse.rdf4j:rdf4j-runtime (Maven): affected all versions; fixed in 2.4.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000644/ (Markdown: https://insights.sbomify.com/CVE-2018-1000644/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000644
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000644
- OSV: https://osv.dev/vulnerability/CVE-2018-1000644

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000644/
Summaries are generated and may contain mistakes; the official description above is the record.
