{"answers":{"affected":"3 open source packages ship an affected version, including flask and Flask. It affects 4 products.","exploited":"There is no known exploitation of CVE-2018-1000656 in the wild and no public exploit code.","fix":"Upgrade flask to 0.12.3 or later.","what":"CVE-2018-1000656 is a high-severity denial of service vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000656 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000656 is a high-severity denial of service vulnerability in n/a, published on 20 Aug 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000656 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- flask (PyPI): affected all versions; fixed in 0.12.3\n- flask (PyPI): affected all versions; fixed in 0.12.3\n- Flask (PyPI): affected all versions; fixed in 0.12.3\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000656/ (Markdown: https://insights.sbomify.com/CVE-2018-1000656/index.md)","id":"CVE-2018-1000656","markdown":"https://insights.sbomify.com/CVE-2018-1000656/index.md","name":"CVE-2018-1000656","record":{"aliases":["DEBIAN-CVE-2018-1000656","DLA-1892-1","GHSA-562c-5r94-xh97","PYSEC-2018-66","RHSA-2020:0870","SUSE-SU-2019:0657-1","UBUNTU-CVE-2018-1000656","USN-4378-1","openSUSE-SU-2019:1112-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Flask web framework","requires_auth":"none","summary":"An attacker can cause a denial of service by sending JSON data with incorrect encoding, leading to excessive memory usage in the Flask web framework.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"active_iq","vendor":"netapp"},{"product":"hyper_converged_infrastructure","vendor":"netapp"},{"product":"ontap_select_deploy_utility","vendor":"netapp"},{"product":"flask","vendor":"palletsprojects"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"The Pallets Project flask version Before 0.12.3 contains a CWE-20: Improper Input Validation vulnerability in flask that can result in Large amount of memory usage possibly leading to denial of service. This attack appear to be exploitable via Attacker provides JSON data in incorrect encoding. This vulnerability appears to have been fixed in 0.12.3. NOTE: this may overlap CVE-2019-1010083.","ecosystems":["PyPI","Red Hat:rhel_extras_other:7","SUSE:Linux Enterprise Module for Basesystem 15","SUSE:Linux Enterprise Module for Package Hub 15","openSUSE:Leap 15.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Flask is vulnerable to Denial of Service via incorrect encoding of JSON data","id":"CVE-2018-1000656","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":7,"n_references":5,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-1000657"},"packages":[{"ecosystem":"PyPI","fixed":["0.12.3"],"introduced":["0"],"last_affected":[],"package":"Flask","purl":null,"source":"GHSA-562c-5r94-xh97"},{"ecosystem":"PyPI","fixed":["0.12.3"],"introduced":["0"],"last_affected":[],"package":"flask","purl":"pkg:pypi/flask","source":"GHSA-562c-5r94-xh97"},{"ecosystem":"PyPI","fixed":["0.12.3"],"introduced":["0"],"last_affected":[],"package":"flask","purl":"pkg:pypi/flask","source":"PYSEC-2018-66"},{"ecosystem":"Red Hat:rhel_extras_other:7","fixed":["1:0.10.1-5.el7_7"],"introduced":["0"],"last_affected":[],"package":"python-flask","purl":"pkg:rpm/redhat/python-flask","source":"RHSA-2020:0870"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15","fixed":["0.12.4-3.3.26"],"introduced":["0"],"last_affected":[],"package":"python-Flask","purl":"pkg:rpm/suse/python-Flask\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015","source":"SUSE-SU-2019:0657-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Package Hub 15","fixed":["0.12.4-3.3.26"],"introduced":["0"],"last_affected":[],"package":"python-Flask","purl":"pkg:rpm/suse/python-Flask\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Package%20Hub%2015","source":"SUSE-SU-2019:0657-1"},{"ecosystem":"openSUSE:Leap 15.0","fixed":["0.12.4-lp150.2.3.1"],"introduced":["0"],"last_affected":[],"package":"python-Flask","purl":"pkg:rpm/opensuse/python-Flask\u0026distro=openSUSE%20Leap%2015.0","source":"openSUSE-SU-2019:1112-1"}],"prev":{"headline":"Null dereference in n/a","id":"CVE-2018-1000655"},"products":["n/a"],"published":"2018-08-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"CC BY 4.0","name":"Red Hat","prefix":"RHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service by sending JSON data with incorrect encoding, leading to excessive memory usage in the Flask web framework.","url":"https://insights.sbomify.com/CVE-2018-1000656/"}