CVE-2018-1000670 Cross-site scripting in n/a
Cross-site scripting in Koha allows attackers to hijack sessions and escalate privileges via social engineering.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- None listed
What is CVE-2018-1000670?
CVE-2018-1000670 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Scripting (XSS) vulnerability in Multiple fields on multiple pages including /cgi-bin/koha/acqui/supplier.pl?op=enter , /cgi-bin/koha/circ/circulation.pl?borrowernumber=[number] , /cgi-bin/koha/serials/subscription-add.pl that can result in Privilege escalation by taking control of higher privileged users browser sessions. This attack appear to be exploitable via Victims must be socially engineered to visit a vulnerable webpage containing malicious payload. This vulnerability appears to have been fixed in 17.11.
Weakness: CWE-79
Which versions are affected by CVE-2018-1000670?
It affects 1 product.
Products include Koha Koha.
How do I fix CVE-2018-1000670?
No fix has been published for CVE-2018-1000670 yet. Limit exposure of the affected software until one is available.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1000670 being exploited?
There is no known exploitation of CVE-2018-1000670 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-jmgp-hv54-4jff.