{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000670 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-1000670 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-1000670 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000670 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000670 is a medium-severity cross-site scripting vulnerability in n/a, published on 6 Sep 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000670 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000670/ (Markdown: https://insights.sbomify.com/CVE-2018-1000670/index.md)","id":"CVE-2018-1000670","markdown":"https://insights.sbomify.com/CVE-2018-1000670/index.md","name":"CVE-2018-1000670","record":{"aliases":["GHSA-jmgp-hv54-4jff"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"Koha Library System","requires_auth":"none","summary":"Cross-site scripting in Koha allows attackers to hijack sessions and escalate privileges via social engineering.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"koha","vendor":"koha"}],"cvss":{"score":6.1,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Scripting (XSS) vulnerability in Multiple fields on multiple pages including /cgi-bin/koha/acqui/supplier.pl?op=enter , /cgi-bin/koha/circ/circulation.pl?borrowernumber=[number] , /cgi-bin/koha/serials/subscription-add.pl that can result in Privilege escalation by taking control of higher privileged users browser sessions. This attack appear to be exploitable via Victims must be socially engineered to visit a vulnerable webpage containing malicious payload. This vulnerability appears to have been fixed in 17.11.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":false,"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000670","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2018"},"n_packages":0,"n_references":1,"next":{"headline":"Open redirect in n/a","id":"CVE-2018-1000671"},"packages":[],"prev":{"headline":"KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Request Forgery (CSRF) vulnera","id":"CVE-2018-1000669"},"products":["n/a"],"published":"2018-09-06","related":[{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2014-1924","kev_date_added":null,"published":"2020-01-24"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2014-1925","kev_date_added":null,"published":"2020-01-24"},{"cvss_score":9.8,"headline":"SQL injection in n/a","id":"CVE-2015-4633","kev_date_added":null,"published":"2018-10-18"},{"cvss_score":9.6,"headline":"Command injection in n/a","id":"CVE-2024-28739","kev_date_added":null,"published":"2024-08-06"},{"cvss_score":8.8,"headline":"Code injection in n/a","id":"CVE-2024-24337","kev_date_added":null,"published":"2024-02-12"},{"cvss_score":8.8,"headline":"KOHA Library System version 16.11.x (up until 16.11.13) and 17.05.x (up until 17.05.05) contains a Cross Site Request Forgery (CSRF) vulnera","id":"CVE-2018-1000669","kev_date_added":null,"published":"2018-09-06"},{"cvss_score":8.8,"headline":"Cross-site scripting in n/a","id":"CVE-2015-4639","kev_date_added":null,"published":"2017-07-21"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"Cross-site scripting in Koha allows attackers to hijack sessions and escalate privileges via social engineering.","url":"https://insights.sbomify.com/CVE-2018-1000670/"}