CVE-2018-1000807 PyOpenSSL Use-After-Free vulnerability
A use-after-free flaw in pyopenssl allows attackers to cause denial of service or execute arbitrary code via crafted X509 objects.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2018-1000807?
CVE-2018-1000807 is a high-severity use after free vulnerability in Canonical Ubuntu Linux, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Python Cryptographic Authority pyopenssl version prior to version 17.5.0 contains a CWE-416: Use After Free vulnerability in X509 object handling that can result in Use after free can lead to possible denial of service or remote code execution.. This attack appear to be exploitable via Depends on the calling application and if it retains a reference to the memory.. This vulnerability appears to have been fixed in 17.5.0.
Weakness: CWE-416
Which versions are affected by CVE-2018-1000807?
3 open source packages ship an affected version, including pyopenssl. It affects 6 products.
| Package | Affected | Fixed in |
|---|---|---|
pyopenssl PyPI | All versions | 17.5.0 |
pyopenssl PyPI | All versions | 17.5.0 |
pyopenssl PyPI | All versions | 17.5.0 |
Linux distribution packages (3)
python-pyOpenSSL SUSE:Linux Enterprise Server 12 SP5-LTSS | All versions | 17.1.0-4.29.1 |
python-pyOpenSSL SUSE:Linux Enterprise Server LTSS Extended Security 12 SP5 | All versions | 17.1.0-4.29.1 |
python-pyOpenSSL SUSE:Linux Enterprise Server for SAP Applications 12 SP5 | All versions | 17.1.0-4.29.1 |
Products include Canonical Ubuntu Linux, Pyopenssl Pyopenssl, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Workstation, Redhat Openstack.
How do I fix CVE-2018-1000807?
Upgrade pyopenssl to 17.5.0 or later.
Upgrade to the fixed version. These bugs are found with fuzzing and sanitisers and avoided by memory-safe languages. More about Use after free.
Is CVE-2018-1000807 being exploited?
There is no known exploitation of CVE-2018-1000807 in the wild and no public exploit code.
Other vulnerabilities in Canonical Ubuntu Linux
Sources
Also known as ALPINE-CVE-2018-1000807, DEBIAN-CVE-2018-1000807, GHSA-p28m-34f6-967q, PYSEC-2018-23, SUSE-SU-2024:3749-1, UBUNTU-CVE-2018-1000807.