{"answers":{"affected":"3 open source packages ship an affected version, including pyopenssl. It affects 7 products.","exploited":"There is no known exploitation of CVE-2018-1000808 in the wild and no public exploit code.","fix":"Upgrade pyopenssl to 17.5.0 or later.","what":"CVE-2018-1000808 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000808 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000808 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000808 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- pyopenssl (PyPI): affected all versions; fixed in 17.5.0\n- pyopenssl (PyPI): affected all versions; fixed in 17.5.0\n- pyopenssl (PyPI): affected all versions; fixed in 17.5.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000808/ (Markdown: https://insights.sbomify.com/CVE-2018-1000808/index.md)","id":"CVE-2018-1000808","markdown":"https://insights.sbomify.com/CVE-2018-1000808/index.md","name":"CVE-2018-1000808","record":{"aliases":["ALPINE-CVE-2018-1000808","DEBIAN-CVE-2018-1000808","GHSA-2rcm-phc9-3945","PYSEC-2018-24","UBUNTU-CVE-2018-1000808"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Python cryptography library","requires_auth":"none","summary":"A memory leak in pyopenssl's PKCS #12 store handling can lead to denial of service by exhausting system memory during certificate reloads.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"ubuntu_linux","vendor":"canonical"},{"product":"pyopenssl","vendor":"pyopenssl_project"},{"product":"enterprise_linux_desktop","vendor":"redhat"},{"product":"enterprise_linux_server","vendor":"redhat"},{"product":"enterprise_linux_workstation","vendor":"redhat"},{"product":"gluster_storage","vendor":"redhat"},{"product":"openstack","vendor":"redhat"}],"cvss":{"score":5.9,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-404","name":"Improper Resource Shutdown or Release"}],"description":"Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Pyopenssl Incorrect Memory Management","id":"CVE-2018-1000808","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":"canonical:ubuntu_linux","products":["canonical:ubuntu_linux","redhat:enterprise_linux_desktop","redhat:enterprise_linux_server","redhat:enterprise_linux_workstation","redhat:openstack"],"type":"denial_of_service","year":"2018"},"n_packages":3,"n_references":4,"next":{"headline":"privacyIDEA Improper Input Validation vulnerability","id":"CVE-2018-1000809"},"packages":[{"ecosystem":"PyPI","fixed":["17.5.0"],"introduced":["0"],"last_affected":[],"package":"pyopenssl","purl":null,"source":"GHSA-2rcm-phc9-3945"},{"ecosystem":"PyPI","fixed":["17.5.0"],"introduced":["0"],"last_affected":[],"package":"pyopenssl","purl":"pkg:pypi/pyopenssl","source":"GHSA-2rcm-phc9-3945"},{"ecosystem":"PyPI","fixed":["17.5.0"],"introduced":["0"],"last_affected":[],"package":"pyopenssl","purl":"pkg:pypi/pyopenssl","source":"PYSEC-2018-24"}],"prev":{"headline":"PyOpenSSL Use-After-Free vulnerability","id":"CVE-2018-1000807"},"products":["n/a"],"published":"2018-10-08","related":[{"cvss_score":9.8,"headline":"SaltStack Salt Authentication Bypass","id":"CVE-2020-11651","kev_date_added":"2021-11-03","published":"2020-04-30"},{"cvss_score":9.8,"headline":"OpenSMTPD Remote Code Execution","id":"CVE-2020-7247","kev_date_added":"2022-03-25","published":"2020-01-29"},{"cvss_score":9.8,"headline":"Exim Out-of-bounds Write","id":"CVE-2019-16928","kev_date_added":"2022-03-03","published":"2019-09-27"},{"cvss_score":9.8,"headline":"Exim Buffer Overflow","id":"CVE-2018-6789","kev_date_added":"2021-11-03","published":"2018-02-08"},{"cvss_score":9.8,"headline":"Oracle Java SE and Java SE Embedded Remote Code Execution","id":"CVE-2015-2590","kev_date_added":"2022-03-03","published":"2015-07-16"},{"cvss_score":9.8,"headline":"Oracle JRE Remote Code Execution","id":"CVE-2013-0422","kev_date_added":"2022-05-25","published":"2013-01-10"},{"cvss_score":9.8,"headline":"Oracle Java SE Runtime Environment (JRE) Arbitrary Code Execution","id":"CVE-2011-3544","kev_date_added":"2022-03-03","published":"2011-10-19"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"A memory leak in pyopenssl's PKCS #12 store handling can lead to denial of service by exhausting system memory during certificate reloads.","url":"https://insights.sbomify.com/CVE-2018-1000808/"}