# CVE-2018-1000808: Pyopenssl Incorrect Memory Management

> A memory leak in pyopenssl's PKCS #12 store handling can lead to denial of service by exhausting system memory during certificate reloads.

- **Severity:** Medium 5.9 (`CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2018
- **Updated:** 5 Aug 2024
- **Also known as:** ALPINE-CVE-2018-1000808, DEBIAN-CVE-2018-1000808, GHSA-2rcm-phc9-3945, PYSEC-2018-24, UBUNTU-CVE-2018-1000808

## What is CVE-2018-1000808?

CVE-2018-1000808 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Python Cryptographic Authority pyopenssl version Before 17.5.0 contains a CWE - 401 : Failure to Release Memory Before Removing Last Reference vulnerability in PKCS #12 Store that can result in Denial of service if memory runs low or is exhausted. This attack appear to be exploitable via Depends upon calling application, however it could be as simple as initiating a TLS connection. Anything that would cause the calling application to reload certificates from a PKCS #12 store.. This vulnerability appears to have been fixed in 17.5.0.

Weakness: CWE-404 (Improper Resource Shutdown or Release)

## Which versions are affected by CVE-2018-1000808?

3 open source packages ship an affected version, including pyopenssl. It affects 7 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pyopenssl` | PyPI | All versions | 17.5.0 |
| `pyopenssl` | PyPI | All versions | 17.5.0 |
| `pyopenssl` | PyPI | All versions | 17.5.0 |

Products: Canonical Ubuntu Linux, Pyopenssl Project Pyopenssl, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Server, Redhat Enterprise Linux Workstation, Redhat Gluster Storage, Redhat Openstack.

## How do I fix CVE-2018-1000808?

Upgrade pyopenssl to 17.5.0 or later.

## Is CVE-2018-1000808 being exploited?

There is no known exploitation of CVE-2018-1000808 in the wild and no public exploit code.

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000808 and fix it if it is affected.

What it is: CVE-2018-1000808 is a medium-severity denial of service vulnerability in Canonical Ubuntu Linux, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000808 in the wild and no public exploit code.

Affected packages and fixed versions:
- pyopenssl (PyPI): affected all versions; fixed in 17.5.0
- pyopenssl (PyPI): affected all versions; fixed in 17.5.0
- pyopenssl (PyPI): affected all versions; fixed in 17.5.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000808/ (Markdown: https://insights.sbomify.com/CVE-2018-1000808/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000808
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000808
- OSV: https://osv.dev/vulnerability/CVE-2018-1000808

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000808/
Summaries are generated and may contain mistakes; the official description above is the record.
