CVE-2018-1000809 privacyIDEA Improper Input Validation vulnerability

High 7.5 Published Updated

An attacker can cause a Denial-of-Service in privacyIDEA by sending a specific HTTP request to the token validation API.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000809?

CVE-2018-1000809 is a high-severity denial of service vulnerability in n/a, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=<space>&pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.

Weakness: CWE-20

Which versions are affected by CVE-2018-1000809?

3 open source packages ship an affected version, including privacyidea and privacyIDEA. It affects 1 product.

PackageAffectedFixed in
privacyidea PyPIAll versions2.23.2
privacyidea PyPIAll versions2.23.2
privacyIDEA PyPIAll versions2.23.2

Products include Privacyidea Privacyidea.

How do I fix CVE-2018-1000809?

Upgrade privacyidea to 2.23.2 or later.

Upgrade, then put limits on request size, rate and nesting depth so one client cannot exhaust the service. More about Denial of service.

Is CVE-2018-1000809 being exploited?

There is no known exploitation of CVE-2018-1000809 in the wild and no public exploit code.

Sources

Also known as GHSA-7qqv-r2q4-jxhm, PYSEC-2018-20.

Is CVE-2018-1000809 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free