{"answers":{"affected":"3 open source packages ship an affected version, including privacyidea and privacyIDEA. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000809 in the wild and no public exploit code.","fix":"Upgrade privacyidea to 2.23.2 or later.","what":"CVE-2018-1000809 is a high-severity denial of service vulnerability in n/a, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000809 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000809 is a high-severity denial of service vulnerability in n/a, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000809 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- privacyidea (PyPI): affected all versions; fixed in 2.23.2\n- privacyidea (PyPI): affected all versions; fixed in 2.23.2\n- privacyIDEA (PyPI): affected all versions; fixed in 2.23.2\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000809/ (Markdown: https://insights.sbomify.com/CVE-2018-1000809/index.md)","id":"CVE-2018-1000809","markdown":"https://insights.sbomify.com/CVE-2018-1000809/index.md","name":"CVE-2018-1000809","record":{"aliases":["GHSA-7qqv-r2q4-jxhm","PYSEC-2018-20"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"privacyIDEA authentication","requires_auth":"none","summary":"An attacker can cause a Denial-of-Service in privacyIDEA by sending a specific HTTP request to the token validation API.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"privacyidea","vendor":"privacyidea"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=\u003cspace\u003e\u0026pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"privacyIDEA Improper Input Validation vulnerability","id":"CVE-2018-1000809","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Integer overflow in n/a","id":"CVE-2018-1000810"},"packages":[{"ecosystem":"PyPI","fixed":["2.23.2"],"introduced":["0"],"last_affected":[],"package":"privacyIDEA","purl":null,"source":"GHSA-7qqv-r2q4-jxhm"},{"ecosystem":"PyPI","fixed":["2.23.2"],"introduced":["0"],"last_affected":[],"package":"privacyidea","purl":"pkg:pypi/privacyidea","source":"GHSA-7qqv-r2q4-jxhm"},{"ecosystem":"PyPI","fixed":["2.23.2"],"introduced":["0"],"last_affected":[],"package":"privacyidea","purl":"pkg:pypi/privacyidea","source":"PYSEC-2018-20"}],"prev":{"headline":"Pyopenssl Incorrect Memory Management","id":"CVE-2018-1000808"},"products":["n/a"],"published":"2018-10-08","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can cause a Denial-of-Service in privacyIDEA by sending a specific HTTP request to the token validation API.","url":"https://insights.sbomify.com/CVE-2018-1000809/"}