# CVE-2018-1000809: privacyIDEA Improper Input Validation vulnerability

> An attacker can cause a Denial-of-Service in privacyIDEA by sending a specific HTTP request to the token validation API.

- **Severity:** High 7.5 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Oct 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-7qqv-r2q4-jxhm, PYSEC-2018-20

## What is CVE-2018-1000809?

CVE-2018-1000809 is a high-severity denial of service vulnerability in n/a, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

privacyIDEA version 2.23.1 and earlier contains a Improper Input Validation vulnerability in token validation api that can result in Denial-of-Service. This attack appear to be exploitable via http request with user=<space>&pass= to /validate/check url. This vulnerability appears to have been fixed in 2.23.2.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1000809?

3 open source packages ship an affected version, including privacyidea and privacyIDEA. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `privacyidea` | PyPI | All versions | 2.23.2 |
| `privacyidea` | PyPI | All versions | 2.23.2 |
| `privacyIDEA` | PyPI | All versions | 2.23.2 |

Products: Privacyidea Privacyidea.

## How do I fix CVE-2018-1000809?

Upgrade privacyidea to 2.23.2 or later.

## Is CVE-2018-1000809 being exploited?

There is no known exploitation of CVE-2018-1000809 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000809 and fix it if it is affected.

What it is: CVE-2018-1000809 is a high-severity denial of service vulnerability in n/a, published on 8 Oct 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000809 in the wild and no public exploit code.

Affected packages and fixed versions:
- privacyidea (PyPI): affected all versions; fixed in 2.23.2
- privacyidea (PyPI): affected all versions; fixed in 2.23.2
- privacyIDEA (PyPI): affected all versions; fixed in 2.23.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000809/ (Markdown: https://insights.sbomify.com/CVE-2018-1000809/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000809
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000809
- OSV: https://osv.dev/vulnerability/CVE-2018-1000809

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000809/
Summaries are generated and may contain mistakes; the official description above is the record.
