{"answers":{"affected":"3 open source packages ship an affected version, including aiohttp-session. It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000814 in the wild and no public exploit code.","fix":"Upgrade aiohttp-session to 2.7.0 or later.","what":"CVE-2018-1000814 is a medium-severity vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-1000814 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000814 is a medium-severity vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-1000814 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- aiohttp-session (PyPI): affected all versions; fixed in 2.7.0\n- aiohttp-session (PyPI): affected all versions; fixed in 2.7.0\n- aiohttp-session (PyPI): affected all versions; fixed in 2.7.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000814/ (Markdown: https://insights.sbomify.com/CVE-2018-1000814/index.md)","id":"CVE-2018-1000814","markdown":"https://insights.sbomify.com/CVE-2018-1000814/index.md","name":"CVE-2018-1000814","record":{"aliases":["GHSA-mr4x-c4v9-x729","PYSEC-2018-35"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Python session library","requires_auth":"low_privilege","summary":"Attackers can maintain persistent sessions by reusing expired encrypted cookies, bypassing session expiration controls in aiohttp-session.","user_interaction":"not_required","vuln_class":"security_feature_bypass"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"aiohttp_session","vendor":"aio-libs"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N","version":"3.1"},"cwes":[{"id":"CWE-613","name":"DEPRECATED: Insufficient Session Expiration"}],"description":"aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan. This attack appear to be exploitable via Recreation of a cookie post-expiry with the same value.","ecosystems":["PyPI"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"aiohttp-session creates non-expiring sessions","id":"CVE-2018-1000814","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"PyPI","product":null,"products":[],"type":"security_feature_bypass","year":"2018"},"n_packages":3,"n_references":2,"next":{"headline":"Security feature bypass in n/a","id":"CVE-2018-1000815"},"packages":[{"ecosystem":"PyPI","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"aiohttp-session","purl":null,"source":"GHSA-mr4x-c4v9-x729"},{"ecosystem":"PyPI","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"aiohttp-session","purl":"pkg:pypi/aiohttp-session","source":"GHSA-mr4x-c4v9-x729"},{"ecosystem":"PyPI","fixed":["2.7.0"],"introduced":["0"],"last_affected":[],"package":"aiohttp-session","purl":"pkg:pypi/aiohttp-session","source":"PYSEC-2018-35"}],"prev":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000813"},"products":["n/a"],"published":"2018-12-20","related":[{"cvss_score":6.5,"headline":"aiohttp-session Session Fixation vulnerability","id":"CVE-2018-1000519","kev_date_added":null,"published":"2018-06-26"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"PyPA Advisory Database","prefix":"PYSEC"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-17","vendors":["n/a"]},"summary":"Attackers can maintain persistent sessions by reusing expired encrypted cookies, bypassing session expiration controls in aiohttp-session.","url":"https://insights.sbomify.com/CVE-2018-1000814/"}