# CVE-2018-1000814: aiohttp-session creates non-expiring sessions

> Attackers can maintain persistent sessions by reusing expired encrypted cookies, bypassing session expiration controls in aiohttp-session.

- **Severity:** Medium 6.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Dec 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-mr4x-c4v9-x729, PYSEC-2018-35

## What is CVE-2018-1000814?

CVE-2018-1000814 is a medium-severity vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

aio-libs aiohttp-session version 2.6.0 and earlier contains a Other/Unknown vulnerability in EncryptedCookieStorage and NaClCookieStorage that can result in Non-expiring sessions / Infinite lifespan. This attack appear to be exploitable via Recreation of a cookie post-expiry with the same value.

Weakness: CWE-613 (DEPRECATED: Insufficient Session Expiration)

## Which versions are affected by CVE-2018-1000814?

3 open source packages ship an affected version, including aiohttp-session. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `aiohttp-session` | PyPI | All versions | 2.7.0 |
| `aiohttp-session` | PyPI | All versions | 2.7.0 |
| `aiohttp-session` | PyPI | All versions | 2.7.0 |

Products: Aio-Libs Aiohttp Session.

## How do I fix CVE-2018-1000814?

Upgrade aiohttp-session to 2.7.0 or later.

## Is CVE-2018-1000814 being exploited?

There is no known exploitation of CVE-2018-1000814 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000519](https://insights.sbomify.com/CVE-2018-1000519/): aiohttp-session Session Fixation vulnerability (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000814 and fix it if it is affected.

What it is: CVE-2018-1000814 is a medium-severity vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000814 in the wild and no public exploit code.

Affected packages and fixed versions:
- aiohttp-session (PyPI): affected all versions; fixed in 2.7.0
- aiohttp-session (PyPI): affected all versions; fixed in 2.7.0
- aiohttp-session (PyPI): affected all versions; fixed in 2.7.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000814/ (Markdown: https://insights.sbomify.com/CVE-2018-1000814/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000814
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000814
- OSV: https://osv.dev/vulnerability/CVE-2018-1000814

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000814/
Summaries are generated and may contain mistakes; the official description above is the record.
