CVE-2018-1000826 Microweber XSS Vulnerability

Medium 6.1 Published Updated

An attacker can execute arbitrary JavaScript code via the Admin login form template in Microweber.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-1000826?

CVE-2018-1000826 is a medium-severity cross-site scripting vulnerability in Microweber Microweber, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Microweber version <= 1.0.7 contains a Cross Site Scripting (XSS) vulnerability in Admin login form template that can result in Execution of JavaScript code.

Weakness: CWE-79

Which versions are affected by CVE-2018-1000826?

2 open source packages ship an affected version, including microweber/microweber. It affects 1 product.

PackageAffectedFixed in
microweber/microweber PackagistAll versions1.1
microweber/microweber PackagistAll versions1.1

Products include Microweber Microweber.

How do I fix CVE-2018-1000826?

Upgrade microweber/microweber to 1.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1000826 being exploited?

There is no known exploitation of CVE-2018-1000826 in the wild and no public exploit code.

All Microweber Microweber vulnerabilities

Sources

Also known as GHSA-xmcr-x5x3-gjfx.

Is CVE-2018-1000826 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free