CVE-2018-1000841 Cross-site scripting in n/a

Medium 6.1 Published Updated

An attacker can execute arbitrary JavaScript in a victim's browser via a Cross-Site Scripting vulnerability in the verify.php page of Zend.To.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2018-1000841?

CVE-2018-1000841 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

Zend.To version Prior to 5.15-1 contains a Cross Site Scripting (XSS) vulnerability in The verify.php page that can result in An attacker could execute arbitrary Javascript code in the context of the victim's browser.. This attack appear to be exploitable via HTTP POST request. This vulnerability appears to have been fixed in 5.16-1 Beta.

Weakness: CWE-79

Which versions are affected by CVE-2018-1000841?

It affects 1 product.

Products include Zend Zendto.

How do I fix CVE-2018-1000841?

No fix has been published for CVE-2018-1000841 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1000841 being exploited?

There is no known exploitation of CVE-2018-1000841 in the wild and no public exploit code.

Sources

Also known as GHSA-ccj4-7v26-43xx.

Is CVE-2018-1000841 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free