CVE-2018-1000842 Fat Free CRM vulnerable to Cross-site Scripting
Attackers can execute arbitrary JavaScript in user browsers via XSS in FatFreeCRM, potentially leading to session hijacking or data theft.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-1000842?
CVE-2018-1000842 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
FatFreeCRM version <=0.14.1, >=0.15.0 <=0.15.1, >=0.16.0 <=0.16.3, >=0.17.0 <=0.17.2, ==0.18.0 contains a Cross Site Scripting (XSS) vulnerability in commit 6d60bc8ed010c4eda05d6645c64849f415f68d65 that can result in Javascript execution. This attack appear to be exploitable via Content with Javascript payload will be executed on end user browsers when they visit the page. This vulnerability appears to have been fixed in 0.18.1, 0.17.3, 0.16.4, 0.15.2, 0.14.2.
Weakness: CWE-79
Which versions are affected by CVE-2018-1000842?
10 open source packages ship an affected version, including fat_free_crm. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
fat_free_crm RubyGems | All versions | 0.14.2 |
fat_free_crm RubyGems | All versions | 0.14.2 |
fat_free_crm RubyGems | From 0.15.0 | 0.15.2 |
fat_free_crm RubyGems | From 0.15.0 | 0.15.2 |
fat_free_crm RubyGems | From 0.16.0 | 0.16.4 |
fat_free_crm RubyGems | From 0.16.0 | 0.16.4 |
4 more packages
fat_free_crm RubyGems | From 0.17.0 | 0.17.3 |
fat_free_crm RubyGems | From 0.17.0 | 0.17.3 |
fat_free_crm RubyGems | From 0.18.0 | 0.18.1 |
fat_free_crm RubyGems | From 0.18.0 | 0.18.1 |
Products include Fatfreecrm Fatfreecrm.
How do I fix CVE-2018-1000842?
Upgrade fat_free_crm to a fixed version for your release line: 0.14.2, 0.15.2, 0.16.4 or 0.17.3.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-1000842 being exploited?
There is no known exploitation of CVE-2018-1000842 in the wild and no public exploit code.
Other vulnerabilities in n/a
Sources
Also known as GHSA-j5rj-g695-342r.