# CVE-2018-1000842: Fat Free CRM vulnerable to Cross-site Scripting

> Attackers can execute arbitrary JavaScript in user browsers via XSS in FatFreeCRM, potentially leading to session hijacking or data theft.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 20 Dec 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-j5rj-g695-342r

## What is CVE-2018-1000842?

CVE-2018-1000842 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

FatFreeCRM version <=0.14.1, >=0.15.0 <=0.15.1, >=0.16.0 <=0.16.3, >=0.17.0 <=0.17.2, ==0.18.0 contains a Cross Site Scripting (XSS) vulnerability in commit 6d60bc8ed010c4eda05d6645c64849f415f68d65 that can result in Javascript execution. This attack appear to be exploitable via Content with Javascript payload will be executed on end user browsers when they visit the page. This vulnerability appears to have been fixed in 0.18.1, 0.17.3, 0.16.4, 0.15.2, 0.14.2.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000842?

10 open source packages ship an affected version, including fat_free_crm. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `fat_free_crm` | RubyGems | All versions | 0.14.2 |
| `fat_free_crm` | RubyGems | All versions | 0.14.2 |
| `fat_free_crm` | RubyGems | From 0.15.0 | 0.15.2 |
| `fat_free_crm` | RubyGems | From 0.15.0 | 0.15.2 |
| `fat_free_crm` | RubyGems | From 0.16.0 | 0.16.4 |
| `fat_free_crm` | RubyGems | From 0.16.0 | 0.16.4 |
| `fat_free_crm` | RubyGems | From 0.17.0 | 0.17.3 |
| `fat_free_crm` | RubyGems | From 0.17.0 | 0.17.3 |
| `fat_free_crm` | RubyGems | From 0.18.0 | 0.18.1 |
| `fat_free_crm` | RubyGems | From 0.18.0 | 0.18.1 |

Products: Fatfreecrm Fatfreecrm.

## How do I fix CVE-2018-1000842?

Upgrade fat_free_crm to a fixed version for your release line: 0.14.2, 0.15.2, 0.16.4 or 0.17.3.

## Is CVE-2018-1000842 being exploited?

There is no known exploitation of CVE-2018-1000842 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-39281](https://insights.sbomify.com/CVE-2022-39281/): Remote Denial of Service via Tasks endpoint in fat_free_crm (medium 6.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000842 and fix it if it is affected.

What it is: CVE-2018-1000842 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000842 in the wild and no public exploit code.

Affected packages and fixed versions:
- fat_free_crm (RubyGems): affected all versions; fixed in 0.14.2
- fat_free_crm (RubyGems): affected all versions; fixed in 0.14.2
- fat_free_crm (RubyGems): affected from 0.15.0; fixed in 0.15.2
- fat_free_crm (RubyGems): affected from 0.15.0; fixed in 0.15.2
- fat_free_crm (RubyGems): affected from 0.16.0; fixed in 0.16.4
- fat_free_crm (RubyGems): affected from 0.16.0; fixed in 0.16.4
- fat_free_crm (RubyGems): affected from 0.17.0; fixed in 0.17.3
- fat_free_crm (RubyGems): affected from 0.17.0; fixed in 0.17.3
- fat_free_crm (RubyGems): affected from 0.18.0; fixed in 0.18.1
- fat_free_crm (RubyGems): affected from 0.18.0; fixed in 0.18.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000842/ (Markdown: https://insights.sbomify.com/CVE-2018-1000842/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000842
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000842
- OSV: https://osv.dev/vulnerability/CVE-2018-1000842

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000842/
Summaries are generated and may contain mistakes; the official description above is the record.
