# CVE-2018-1000846: FreshDNS version 1.0.3 and earlier contains a Cross ite Request Forgery (CSRF) vulnerability in All (authenticated) API calls in index.php /


- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Fix available:** No
- **Published:** 20 Dec 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-94mh-vc33-xwv4

## What is CVE-2018-1000846?

CVE-2018-1000846 is a high-severity vulnerability in n/a, published on 20 Dec 2018. 

### Official description

FreshDNS version 1.0.3 and earlier contains a Cross ite Request Forgery (CSRF) vulnerability in All (authenticated) API calls in index.php / class.manager.php that can result in Editing domains and zones with victim's privileges. This attack appear to be exploitable via Victim must open a website containing attacker's javascript. This vulnerability appears to have been fixed in 1.0.5 and later.

Weakness: CWE-352 (Cross-Site Request Forgery)

## Which versions are affected by CVE-2018-1000846?

It affects 1 product.


Products: Freshdns Project Freshdns.

## How do I fix CVE-2018-1000846?

No fix has been published for CVE-2018-1000846 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-1000846 being exploited?

There is no known exploitation of CVE-2018-1000846 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000847](https://insights.sbomify.com/CVE-2018-1000847/): Cross-site scripting in n/a (medium 5.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000846 and fix it if it is affected.

What it is: CVE-2018-1000846 is a high-severity vulnerability in n/a, published on 20 Dec 2018. 
Exploitation: There is no known exploitation of CVE-2018-1000846 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000846/ (Markdown: https://insights.sbomify.com/CVE-2018-1000846/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000846
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000846
- OSV: https://osv.dev/vulnerability/CVE-2018-1000846

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000846/
Summaries are generated and may contain mistakes; the official description above is the record.
