{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000847 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-1000847 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-1000847 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000847 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000847 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000847 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000847/ (Markdown: https://insights.sbomify.com/CVE-2018-1000847/index.md)","id":"CVE-2018-1000847","markdown":"https://insights.sbomify.com/CVE-2018-1000847/index.md","name":"CVE-2018-1000847","record":{"aliases":["GHSA-h7p6-gcj3-4r6j"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","account_takeover"],"network_reachable":"yes","non_default_config":false,"product_category":"FreshDNS","requires_auth":"low_privilege","summary":"An attacker can execute arbitrary JavaScript in an administrator's session by storing a malicious string in their account details, potentially leading to account takeover.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"freshdns","vendor":"freshdns_project"}],"cvss":{"score":5.4,"severity":"medium","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N","version":"3.0"},"cwes":[{"id":"CWE-79","name":"Improper Neutralization of Input During Web Page Generation"}],"description":"FreshDNS version 1.0.3 and prior contains a Cross Site Scripting (XSS) vulnerability in Account data form; Zone editor that can result in Execution of attacker's JavaScript code in victim's session. This attack appear to be exploitable via The attacker stores a specially crafted string as their Full Name in their account details. The victim (e.g. the administrator of the FreshDNS instance) opens the User List in the admin interface.. This vulnerability appears to have been fixed in 1.0.5 and later.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000847","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xss","year":"2018"},"n_packages":0,"n_references":2,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000848"},"packages":[],"prev":{"headline":"FreshDNS version 1.0.3 and earlier contains a Cross ite Request Forgery (CSRF) vulnerability in All (authenticated) API calls in index.php /","id":"CVE-2018-1000846"},"products":["n/a"],"published":"2018-12-20","related":[{"cvss_score":8.8,"headline":"FreshDNS version 1.0.3 and earlier contains a Cross ite Request Forgery (CSRF) vulnerability in All (authenticated) API calls in index.php /","id":"CVE-2018-1000846","kev_date_added":null,"published":"2018-12-20"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can execute arbitrary JavaScript in an administrator's session by storing a malicious string in their account details, potentially leading to account takeover.","url":"https://insights.sbomify.com/CVE-2018-1000847/"}