# CVE-2018-1000847: Cross-site scripting in n/a

> An attacker can execute arbitrary JavaScript in an administrator's session by storing a malicious string in their account details, potentially leading to account takeover.

- **Severity:** Medium 5.4 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Dec 2018
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-h7p6-gcj3-4r6j

## What is CVE-2018-1000847?

CVE-2018-1000847 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

FreshDNS version 1.0.3 and prior contains a Cross Site Scripting (XSS) vulnerability in Account data form; Zone editor that can result in Execution of attacker's JavaScript code in victim's session. This attack appear to be exploitable via The attacker stores a specially crafted string as their Full Name in their account details. The victim (e.g. the administrator of the FreshDNS instance) opens the User List in the admin interface.. This vulnerability appears to have been fixed in 1.0.5 and later.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-1000847?

It affects 1 product.


Products: Freshdns Project Freshdns.

## How do I fix CVE-2018-1000847?

No fix has been published for CVE-2018-1000847 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-1000847 being exploited?

There is no known exploitation of CVE-2018-1000847 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2018-1000846](https://insights.sbomify.com/CVE-2018-1000846/): FreshDNS version 1.0.3 and earlier contains a Cross ite Request Forgery (CSRF) vulnerability in All (authenticated) API calls in index.php / (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000847 and fix it if it is affected.

What it is: CVE-2018-1000847 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000847 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000847/ (Markdown: https://insights.sbomify.com/CVE-2018-1000847/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000847
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000847
- OSV: https://osv.dev/vulnerability/CVE-2018-1000847

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000847/
Summaries are generated and may contain mistakes; the official description above is the record.
