# CVE-2018-1000849: Path traversal in n/a

> A specially crafted APK file allows attackers to write arbitrary data to specified files, leading to remote code execution in Alpine Linux.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 20 Dec 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-fv7m-mhm7-76v2

## What is CVE-2018-1000849?

CVE-2018-1000849 is a high-severity path traversal vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Alpine Linux version Versions prior to 2.6.10, 2.7.6, and 2.10.1 contains a Other/Unknown vulnerability in apk-tools (Alpine Linux' package manager) that can result in Remote Code Execution. This attack appear to be exploitable via A specially crafted APK-file can cause apk to write arbitrary data to an attacker-specified file, due to bugs in handling long link target name and the way a regular file is extracted.. This vulnerability appears to have been fixed in 2.6.10, 2.7.6, and 2.10.1.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1000849?

It affects 1 product.


Products: Alpinelinux Alpine Linux.

## How do I fix CVE-2018-1000849?

No fix has been published for CVE-2018-1000849 yet. Limit exposure of the affected software until one is available.

## Is CVE-2018-1000849 being exploited?

There is no known exploitation of CVE-2018-1000849 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2017-9669](https://insights.sbomify.com/CVE-2017-9669/): Memory corruption in n/a (high 7.8)
- [CVE-2017-9671](https://insights.sbomify.com/CVE-2017-9671/): Memory corruption in n/a (high 7.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000849 and fix it if it is affected.

What it is: CVE-2018-1000849 is a high-severity path traversal vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000849 in the wild and no public exploit code.

Affected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000849/ (Markdown: https://insights.sbomify.com/CVE-2018-1000849/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000849
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000849
- OSV: https://osv.dev/vulnerability/CVE-2018-1000849

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000849/
Summaries are generated and may contain mistakes; the official description above is the record.
