CVE-2018-1000855 Cross Site Scripting (XSS) vulnerability in easymon

Medium 6.1 Published Updated

Reflected XSS in easymon allows attackers to steal cookies via crafted URLs, potentially leading to account takeover.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
Available

What is CVE-2018-1000855?

CVE-2018-1000855 is a medium-severity cross-site scripting vulnerability in n/a, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

Official description

easymon version 1.4 and earlier contains a Cross Site Scripting (XSS) vulnerability in Endpoint where monitoring is mounted that can result in Reflected XSS that affects Firefox. Can be used to steal cookies, depending on the cookie settings.. This attack appear to be exploitable via The victim must click on a crafted URL that contains the XSS payload. This vulnerability appears to have been fixed in 1.4.1 and later.

Weakness: CWE-79

Which versions are affected by CVE-2018-1000855?

2 open source packages ship an affected version, including easymon. It affects 1 product.

PackageAffectedFixed in
easymon RubyGemsAll versions1.4.1
easymon RubyGemsAll versions1.4.1

Products include Basecamp Easymon.

How do I fix CVE-2018-1000855?

Upgrade easymon to 1.4.1 or later.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1000855 being exploited?

There is no known exploitation of CVE-2018-1000855 in the wild and no public exploit code.

Sources

Also known as GHSA-c289-47qf-rvrr.

Is CVE-2018-1000855 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free