# CVE-2018-1000861: Jenkins Stapler Web Framework Deserialization of Untrusted Data

> Attackers can execute arbitrary code on Jenkins servers by crafting malicious URLs that exploit the Stapler web framework.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Yes, since 10 Feb 2022 (CISA KEV)
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2018
- **Updated:** 21 Oct 2025
- **Also known as:** GHSA-hhpm-5cp2-hg4x

## What is CVE-2018-1000861?

CVE-2018-1000861 is a critical code injection vulnerability in Jenkins Jenkins, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A code execution vulnerability exists in the Stapler web framework used by Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in stapler/core/src/main/java/org/kohsuke/stapler/MetaClass.java that allows attackers to invoke some methods on Java objects by accessing crafted URLs that were not intended to be invoked this way.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-1000861?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.138.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.138.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.140 | 2.154 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.140 | 2.154 |

Products: Jenkins Jenkins, Redhat Openshift Container Platform.

## How do I fix CVE-2018-1000861?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.138.4 or 2.154. US federal agencies must fix it by 10 Aug 2022.

## Is CVE-2018-1000861 being exploited?

Yes. Attackers have exploited CVE-2018-1000861 in the wild since at least 10 Feb 2022.

Public exploit code:

- A C# module  to detect if a Jenkins server is vulnerable to the RCE vulnerability found in CVE-2019-1003000 (chained with  CVE-2018-1000861 for pre-auth RCE) (github_poc): https://github.com/1NTheKut/CVE-2019-1003000_RCE-DETECTION
- Jenkins ACL Bypass and Metaprogramming RCE (metasploit)
- CVE-2018-1000861 Exploit (github_poc): https://github.com/smokeintheshell/CVE-2018-1000861
- Vulhub jenkins/CVE-2018-1000861: Jenkins Stapler unauthenticated RCE, run with Isoloom (github_poc): https://github.com/CyberCTF/vulhub-jenkins-cve-2018-1000861
- Jenkins - Remote Command Injection (nuclei): http/cves/2018/CVE-2018-1000861.yaml

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)
- [CVE-2021-21691](https://insights.sbomify.com/CVE-2021-21691/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000861 and fix it if it is affected.

What it is: CVE-2018-1000861 is a critical code injection vulnerability in Jenkins Jenkins, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: Yes. Attackers have exploited CVE-2018-1000861 in the wild since at least 10 Feb 2022.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.138.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.138.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.140; fixed in 2.154
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.140; fixed in 2.154

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000861/ (Markdown: https://insights.sbomify.com/CVE-2018-1000861/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000861
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000861
- OSV: https://osv.dev/vulnerability/CVE-2018-1000861

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000861/
Summaries are generated and may contain mistakes; the official description above is the record.
