CVE-2018-1000863 Improper Limitation of a Pathname to a Restricted Directory in Jenkins

High 8.2 Published Updated

Attackers can submit crafted usernames to corrupt user record storage, preventing legitimate users from logging into Jenkins.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2018-1000863?

CVE-2018-1000863 is a high-severity vulnerability in Jenkins Jenkins, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

A data modification vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in User.java, IdStrategy.java that allows attackers to submit crafted user names that can cause an improper migration of user record storage formats, potentially preventing the victim from logging into Jenkins.

Weakness: CWE-22

Which versions are affected by CVE-2018-1000863?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.

PackageAffectedFixed in
org.jenkins-ci.main:jenkins-core MavenAll versions2.138.4
org.jenkins-ci.main:jenkins-core MavenAll versions2.138.4
org.jenkins-ci.main:jenkins-core MavenFrom 2.1402.154
org.jenkins-ci.main:jenkins-core MavenFrom 2.1402.154

Products include Jenkins Jenkins, Redhat Openshift Container Platform.

How do I fix CVE-2018-1000863?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.138.4 or 2.154.

Is CVE-2018-1000863 being exploited?

There is no known exploitation of CVE-2018-1000863 in the wild and no public exploit code.

All Jenkins Jenkins vulnerabilities

Sources

Also known as GHSA-4jhm-5f7g-75fp.

Is CVE-2018-1000863 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free