# CVE-2018-1000863: Improper Limitation of a Pathname to a Restricted Directory in Jenkins

> Attackers can submit crafted usernames to corrupt user record storage, preventing legitimate users from logging into Jenkins.

- **Severity:** High 8.2 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-4jhm-5f7g-75fp

## What is CVE-2018-1000863?

CVE-2018-1000863 is a high-severity vulnerability in Jenkins Jenkins, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

A data modification vulnerability exists in Jenkins 2.153 and earlier, LTS 2.138.3 and earlier in User.java, IdStrategy.java that allows attackers to submit crafted user names that can cause an improper migration of user record storage formats, potentially preventing the victim from logging into Jenkins.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1000863?

4 open source packages ship an affected version, including org.jenkins-ci.main:jenkins-core. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.138.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | All versions | 2.138.4 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.140 | 2.154 |
| `org.jenkins-ci.main:jenkins-core` | Maven | From 2.140 | 2.154 |

Products: Jenkins Jenkins, Redhat Openshift Container Platform.

## How do I fix CVE-2018-1000863?

Upgrade org.jenkins-ci.main:jenkins-core to a fixed version for your release line: 2.138.4 or 2.154.

## Is CVE-2018-1000863 being exploited?

There is no known exploitation of CVE-2018-1000863 in the wild and no public exploit code.

## Other vulnerabilities in Jenkins Jenkins

- [CVE-2024-23897](https://insights.sbomify.com/CVE-2024-23897/): Jenkins Command Line Interface (CLI) Path Traversal (critical 9.8, exploited in the wild)
- [CVE-2018-1000861](https://insights.sbomify.com/CVE-2018-1000861/): Jenkins Stapler Web Framework Deserialization of Untrusted Data (critical 9.8, exploited in the wild)
- [CVE-2017-1000353](https://insights.sbomify.com/CVE-2017-1000353/): Jenkins Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2015-5317](https://insights.sbomify.com/CVE-2015-5317/): Jenkins User Interface (UI) Information Disclosure (high 7.5, exploited in the wild)
- [CVE-2021-21690](https://insights.sbomify.com/CVE-2021-21690/): Multiple vulnerabilities allow bypassing path filtering of agent-to-controller access control in Jenkins (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000863 and fix it if it is affected.

What it is: CVE-2018-1000863 is a high-severity vulnerability in Jenkins Jenkins, published on 10 Dec 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000863 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.138.4
- org.jenkins-ci.main:jenkins-core (Maven): affected all versions; fixed in 2.138.4
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.140; fixed in 2.154
- org.jenkins-ci.main:jenkins-core (Maven): affected from 2.140; fixed in 2.154

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000863/ (Markdown: https://insights.sbomify.com/CVE-2018-1000863/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000863
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000863
- OSV: https://osv.dev/vulnerability/CVE-2018-1000863

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000863/
Summaries are generated and may contain mistakes; the official description above is the record.
