# CVE-2018-1000866: Jenkins Script Security and Pipeline Groovy Plugins Sandbox Bypass

> Attackers with specific permissions can bypass the Groovy sandbox to execute arbitrary code on the Jenkins master JVM.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-gqhm-4h93-rrhg

## What is CVE-2018-1000866?

CVE-2018-1000866 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 10 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

A sandbox bypass vulnerability exists in Pipeline: Groovy Plugin 2.59 and earlier in groovy-sandbox/src/main/java/org/kohsuke/groovy/sandbox/SandboxTransformer.java, groovy-cps/lib/src/main/java/com/cloudbees/groovy/cps/SandboxCpsTransformer.java that allows attackers with Job/Configure permission, or unauthorized attackers with SCM commit privileges and corresponding pipelines based on Jenkinsfiles set up in Jenkins, to execute arbitrary code on the Jenkins master JVM

Weakness: CWE-269 (Improper Privilege Management)

## Which versions are affected by CVE-2018-1000866?

4 open source packages ship an affected version, including org.jenkins-ci.plugins.workflow:workflow-cps and org.jenkins-ci.plugins:script-security. It affects 2 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.jenkins-ci.plugins.workflow:workflow-cps` | Maven | All versions | 2.60 |
| `org.jenkins-ci.plugins.workflow:workflow-cps` | Maven | All versions | 2.60 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.48 |
| `org.jenkins-ci.plugins:script-security` | Maven | All versions | 1.48 |

Products: Jenkins Pipeline\, Redhat Openshift Container Platform.

## How do I fix CVE-2018-1000866?

Upgrade org.jenkins-ci.plugins.workflow:workflow-cps to 2.60 or later.

## Is CVE-2018-1000866 being exploited?

There is no known exploitation of CVE-2018-1000866 in the wild and no public exploit code.

## Other vulnerabilities in Redhat Openshift Container Platform

- [CVE-2019-1003030](https://insights.sbomify.com/CVE-2019-1003030/): Jenkins Matrix Project Plugin Remote Code Execution (critical 9.9, exploited in the wild)
- [CVE-2022-43402](https://insights.sbomify.com/CVE-2022-43402/): Jenkins Pipeline: Groovy Plugin allows sandbox protection bypass and arbitrary code execution (critical 9.9)
- [CVE-2019-1003041](https://insights.sbomify.com/CVE-2019-1003041/): Sandbox bypass vulnerability in Jenkins Pipeline: Groovy Plugin (critical 9.8)
- [CVE-2022-43407](https://insights.sbomify.com/CVE-2022-43407/): CSRF protection for any URL can be bypassed in Jenkins Pipeline: Input Step Plugin (high 8.8)
- [CVE-2022-25173](https://insights.sbomify.com/CVE-2022-25173/): Improper Neutralization of Special Elements used in an OS Command in Jenkins Pipeline: Groovy Plugin (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000866 and fix it if it is affected.

What it is: CVE-2018-1000866 is a high-severity code injection vulnerability in Redhat Openshift Container Platform, published on 10 Dec 2018. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1000866 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.jenkins-ci.plugins.workflow:workflow-cps (Maven): affected all versions; fixed in 2.60
- org.jenkins-ci.plugins.workflow:workflow-cps (Maven): affected all versions; fixed in 2.60
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.48
- org.jenkins-ci.plugins:script-security (Maven): affected all versions; fixed in 1.48

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000866/ (Markdown: https://insights.sbomify.com/CVE-2018-1000866/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000866
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000866
- OSV: https://osv.dev/vulnerability/CVE-2018-1000866

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000866/
Summaries are generated and may contain mistakes; the official description above is the record.
