CVE-2018-1000870 Cross-site scripting in n/a

Medium 5.4 Published Updated

An attacker can execute arbitrary code in an administrator's browser by manipulating the theme parameter in user settings, which is rendered in the admin panel.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2018-1000870?

CVE-2018-1000870 is a medium-severity cross-site scripting vulnerability in Phpipam Phpipam, published on 20 Dec 2018. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

PHPipam version 1.3.2 and earlier contains a CWE-79 vulnerability in /app/admin/users/print-user.php that can result in Execute code in the victims browser. This attack appear to be exploitable via Attacker change theme parameter in user settings. Admin(Victim) views user in admin-panel and gets exploited.. This vulnerability appears to have been fixed in 1.4.

Weakness: CWE-79

Which versions are affected by CVE-2018-1000870?

It affects 1 product.

Products include Phpipam Phpipam.

How do I fix CVE-2018-1000870?

No fix has been published for CVE-2018-1000870 yet. Limit exposure of the affected software until one is available.

Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.

Is CVE-2018-1000870 being exploited?

There is no known exploitation of CVE-2018-1000870 in the wild and no public exploit code.

All Phpipam Phpipam vulnerabilities

Sources

Also known as GHSA-47mh-7h3c-25q4.

Is CVE-2018-1000870 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free