{"answers":{"affected":"2 open source packages ship an affected version, including com.fasterxml.jackson.datatype:jackson-datatype-jsr310. It affects 6 products.","exploited":"There is no known exploitation of CVE-2018-1000873 in the wild and no public exploit code.","fix":"Upgrade com.fasterxml.jackson.datatype:jackson-datatype-jsr310 to 2.9.8 or later.","what":"CVE-2018-1000873 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000873 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000873 is a medium-severity denial of service vulnerability in Netapp Active Iq Unified Manager, published on 20 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000873 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- com.fasterxml.jackson.datatype:jackson-datatype-jsr310 (Maven): affected all versions; fixed in 2.9.8\n- com.fasterxml.jackson.datatype:jackson-datatype-jsr310 (Maven): affected all versions; fixed in 2.9.8\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000873/ (Markdown: https://insights.sbomify.com/CVE-2018-1000873/index.md)","id":"CVE-2018-1000873","markdown":"https://insights.sbomify.com/CVE-2018-1000873/index.md","name":"CVE-2018-1000873","record":{"aliases":["CLEANSTART-2026-YW54942","GHSA-h4x4-5qp2-wp46","RHLW-2026-7b68982493d0dce4","UBUNTU-CVE-2018-1000873"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"Java JSON library","requires_auth":"none","summary":"Attackers can cause denial of service by deserializing malicious input with large nanosecond values in Jackson Java8 modules.","user_interaction":"required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"jackson-modules-java8","vendor":"fasterxml"},{"product":"active_iq_unified_manager","vendor":"netapp"},{"product":"clusterware","vendor":"oracle"},{"product":"database_server","vendor":"oracle"},{"product":"global_lifecycle_management_opatch","vendor":"oracle"},{"product":"nosql_database","vendor":"oracle"}],"cvss":{"score":6.5,"severity":"medium","source":"nvd","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:H","version":"3.1"},"cwes":[{"id":"CWE-20","name":"Improper Input Validation"}],"description":"Fasterxml Jackson version Before 2.9.8 contains a CWE-20: Improper Input Validation vulnerability in Jackson-Modules-Java8 that can result in Causes a denial-of-service (DoS). This attack appear to be exploitable via The victim deserializes malicious input, specifically very large values in the nanoseconds field of a time value. This vulnerability appears to have been fixed in 2.9.8.","ecosystems":["Maven"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Moderate severity vulnerability that affects com.fasterxml.jackson.datatype:jackson-datatype-jsr353","id":"CVE-2018-1000873","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Maven","product":"netapp:active_iq_unified_manager","products":["netapp:active_iq_unified_manager","oracle:database_server"],"type":"denial_of_service","year":"2018"},"n_packages":2,"n_references":14,"next":{"headline":"Cross-site scripting in n/a","id":"CVE-2018-1000874"},"packages":[{"ecosystem":"Maven","fixed":["2.9.8"],"introduced":["0"],"last_affected":[],"package":"com.fasterxml.jackson.datatype:jackson-datatype-jsr310","purl":null,"source":"GHSA-h4x4-5qp2-wp46"},{"ecosystem":"Maven","fixed":["2.9.8"],"introduced":["0"],"last_affected":[],"package":"com.fasterxml.jackson.datatype:jackson-datatype-jsr310","purl":"pkg:maven/com.fasterxml.jackson.datatype/jackson-datatype-jsr310","source":"GHSA-h4x4-5qp2-wp46"}],"prev":{"headline":"PyKMIP Denial of service vulnerability","id":"CVE-2018-1000872"},"products":["n/a"],"published":"2018-12-20","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"Attackers can cause denial of service by deserializing malicious input with large nanosecond values in Jackson Java8 modules.","url":"https://insights.sbomify.com/CVE-2018-1000873/"}