# CVE-2018-1000888: Archive_Tar contains Potential RCE if filename starts with phar://

> Attackers can achieve remote code execution or arbitrary file deletion via PHP object injection in the Archive_Tar library.

- **Severity:** High 8.8 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 27 Dec 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CLEANSTART-2024-AG03928, DEBIAN-CVE-2018-1000888, DLA-1674-1, DSA-4378-1, GHSA-3q76-jq6m-573p, UBUNTU-CVE-2018-1000888, USN-3857-1

## What is CVE-2018-1000888?

CVE-2018-1000888 is a high-severity unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 27 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

PEAR Archive_Tar version 1.4.3 and earlier contains a CWE-502, CWE-915 vulnerability in the Archive_Tar class. There are several file operations with `$v_header['filename']` as parameter (such as file_exists, is_file, is_dir, etc). When extract is called without a specific prefix path, we can trigger unserialization by crafting a tar file with `phar://[path_to_malicious_phar_file]` as path. Object injection can be used to trigger destruct in the loaded PHP classes, e.g. the Archive_Tar class itself. With Archive_Tar object injection, arbitrary file deletion can occur because `@unlink($this->_temp_tarname)` is called. If another class with useful gadget is loaded, it may possible to cause remote code execution that can result in files being deleted or possibly modified. This vulnerability appears to have been fixed in 1.4.4.

Weakness: CWE-502 (Deserialization of Untrusted Data)

## Which versions are affected by CVE-2018-1000888?

2 open source packages ship an affected version, including pear/archive_tar. It affects 3 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `pear/archive_tar` | Packagist | All versions | 1.4.4 |
| `pear/archive_tar` | Packagist | All versions | 1.4.4 |

Products: Canonical Ubuntu Linux, Debian Debian Linux, Php Pear Archive Tar.

## How do I fix CVE-2018-1000888?

Upgrade pear/archive_tar to 1.4.4 or later.

## Is CVE-2018-1000888 being exploited?

There is no known exploitation of CVE-2018-1000888 in the wild and no public exploit code.

Public exploit code:

- PEAR Archive_Tar < 1.4.4 - PHP Object Injection (exploitdb)

## Other vulnerabilities in Canonical Ubuntu Linux

- [CVE-2020-11651](https://insights.sbomify.com/CVE-2020-11651/): SaltStack Salt Authentication Bypass (critical 9.8, exploited in the wild)
- [CVE-2020-7247](https://insights.sbomify.com/CVE-2020-7247/): OpenSMTPD Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2019-16928](https://insights.sbomify.com/CVE-2019-16928/): Exim Out-of-bounds Write (critical 9.8, exploited in the wild)
- [CVE-2018-6789](https://insights.sbomify.com/CVE-2018-6789/): Exim Buffer Overflow (critical 9.8, exploited in the wild)
- [CVE-2015-2590](https://insights.sbomify.com/CVE-2015-2590/): Oracle Java SE and Java SE Embedded Remote Code Execution (critical 9.8, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1000888 and fix it if it is affected.

What it is: CVE-2018-1000888 is a high-severity unsafe deserialization vulnerability in Canonical Ubuntu Linux, published on 27 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1000888 in the wild and no public exploit code.

Affected packages and fixed versions:
- pear/archive_tar (Packagist): affected all versions; fixed in 1.4.4
- pear/archive_tar (Packagist): affected all versions; fixed in 1.4.4

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1000888/ (Markdown: https://insights.sbomify.com/CVE-2018-1000888/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1000888
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1000888
- OSV: https://osv.dev/vulnerability/CVE-2018-1000888

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1000888/
Summaries are generated and may contain mistakes; the official description above is the record.
