{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-1000889 in the wild and no public exploit code.","fix":"No fix has been published for CVE-2018-1000889 yet. Limit exposure of the affected software until one is available.","what":"CVE-2018-1000889 is a high-severity vulnerability in n/a, published on 27 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2018-1000889 and fix it if it is affected.\n\nWhat it is: CVE-2018-1000889 is a high-severity vulnerability in n/a, published on 27 Dec 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2018-1000889 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-1000889/ (Markdown: https://insights.sbomify.com/CVE-2018-1000889/index.md)","id":"CVE-2018-1000889","markdown":"https://insights.sbomify.com/CVE-2018-1000889/index.md","name":"CVE-2018-1000889","record":{"aliases":["GHSA-frwm-8r3x-crr9"],"analysis":{"component_type":"desktop_application","fix_type":"upgrade","impacts":["data_read","code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Logisim Evolution","requires_auth":"none","summary":"An attacker can cause information disclosure or remote code execution by tricking a user into opening a malicious circuit file in Logisim Evolution.","user_interaction":"required","vuln_class":"xxe"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"logisim-evolution","vendor":"logisim-evolution_project"}],"cvss":{"score":8.8,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H","version":"3.0"},"cwes":[{"id":"CWE-611","name":"Improper Restriction of XML External Entity Reference"}],"description":"Logisim Evolution version 2.14.3 and earlier contains an XML External Entity (XXE) vulnerability in Circuit file loading functionality (loadXmlFrom in src/com/cburch/logisim/file/XmlReader.java) that can result in information leak, possible RCE depending on system configuration. This attack appears to be exploitable via the victim opening a specially crafted circuit file. This vulnerability appears to have been fixed in 2.14.4.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":null,"headline":"XML external entity in n/a","id":"CVE-2018-1000889","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"xxe","year":"2018"},"n_packages":0,"n_references":2,"next":{"headline":"SQL injection in n/a","id":"CVE-2018-1000890"},"packages":[],"prev":{"headline":"Archive_Tar contains Potential RCE if filename starts with phar://","id":"CVE-2018-1000888"},"products":["n/a"],"published":"2018-12-27","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-09-16","vendors":["n/a"]},"summary":"An attacker can cause information disclosure or remote code execution by tricking a user into opening a malicious circuit file in Logisim Evolution.","url":"https://insights.sbomify.com/CVE-2018-1000889/"}