# CVE-2018-1002100: Kubernetes arbitrary file overwrite

> Attackers can overwrite arbitrary local files on the client machine by exploiting insecure tar handling in the kubectl cp command.

- **Severity:** Medium 4.2 (`CVSS:3.0/AV:N/AC:H/PR:H/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 1 Jun 2018
- **Updated:** 16 Sep 2024
- **Also known as:** DEBIAN-CVE-2018-1002100, GHSA-2jq6-ffph-p4h8, GO-2023-1959

## What is CVE-2018-1002100?

CVE-2018-1002100 is a medium-severity path traversal vulnerability in Kubernetes Kubernetes, published on 1 Jun 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

In Kubernetes versions 1.5.x, 1.6.x, 1.7.x, 1.8.x, and prior to version 1.9.6, the kubectl cp command insecurely handles tar data returned from the container, and can be caused to overwrite arbitrary local files.

Weakness: CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2018-1002100?

3 open source packages ship an affected version, including k8s.io/kubernetes. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/kubernetes` | Go | From 1.5.0 | 1.9.6 |
| `k8s.io/kubernetes` | Go | From 1.5.0-alpha.0 | 1.9.6 |
| `k8s.io/kubernetes` | Go | From 1.5.0-alpha.0 | 1.9.6 |

Products: Kubernetes Kubernetes.

## How do I fix CVE-2018-1002100?

Upgrade k8s.io/kubernetes to 1.9.6 or later.

## Is CVE-2018-1002100 being exploited?

There is no known exploitation of CVE-2018-1002100 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes Kubernetes

- [CVE-2018-1002105](https://insights.sbomify.com/CVE-2018-1002105/): Privilege Escalation in Kubernetes (critical 9.8)
- [CVE-2017-1000056](https://insights.sbomify.com/CVE-2017-1000056/): Kubernetes Privilege Escalation (critical 9.8)
- [CVE-2016-1906](https://insights.sbomify.com/CVE-2016-1906/): Authorization bypass in Openshift (critical 9.8)
- [CVE-2023-3676](https://insights.sbomify.com/CVE-2023-3676/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)
- [CVE-2023-3955](https://insights.sbomify.com/CVE-2023-3955/): Kubernetes - Windows nodes - Insufficient input sanitization leads to privilege escalation (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1002100 and fix it if it is affected.

What it is: CVE-2018-1002100 is a medium-severity path traversal vulnerability in Kubernetes Kubernetes, published on 1 Jun 2018. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1002100 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/kubernetes (Go): affected from 1.5.0; fixed in 1.9.6
- k8s.io/kubernetes (Go): affected from 1.5.0-alpha.0; fixed in 1.9.6
- k8s.io/kubernetes (Go): affected from 1.5.0-alpha.0; fixed in 1.9.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1002100/ (Markdown: https://insights.sbomify.com/CVE-2018-1002100/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1002100
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1002100
- OSV: https://osv.dev/vulnerability/CVE-2018-1002100

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1002100/
Summaries are generated and may contain mistakes; the official description above is the record.
