# CVE-2018-1002104: Kubernetes ingress exposes sensitive information

> Attackers can access sensitive Prometheus metrics from the Kubernetes ingress default backend, potentially revealing internal system details.

- **Severity:** Medium 5.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 14 Jan 2020
- **Updated:** 16 Sep 2024
- **Also known as:** GHSA-p3x5-5xpx-9phm

## What is CVE-2018-1002104?

CVE-2018-1002104 is a medium-severity vulnerability in Kubernetes k8s.gcr.io/defaultbackend, published on 14 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Versions < 1.5 of the Kubernetes ingress default backend, which handles invalid ingress traffic, exposed prometheus metrics publicly.

Weakness: CWE-20 (Improper Input Validation), CWE-215 (Insertion of Sensitive Information Into Debugging Code)

## Which versions are affected by CVE-2018-1002104?

2 open source packages ship an affected version, including k8s.io/ingress-nginx. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `k8s.io/ingress-nginx` | Go | All versions | 1.5 |
| `k8s.io/ingress-nginx` | Go | All versions | 1.5 |

Products: Kubernetes Nginx Ingress Controller.

## How do I fix CVE-2018-1002104?

Upgrade k8s.io/ingress-nginx to 1.5 or later.

## Is CVE-2018-1002104 being exploited?

There is no known exploitation of CVE-2018-1002104 in the wild and no public exploit code.

## Other vulnerabilities in Kubernetes k8s.gcr.io/defaultbackend

- [CVE-2026-4342](https://insights.sbomify.com/CVE-2026-4342/): ingress-nginx comment-based nginx configuration injection (high 8.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1002104 and fix it if it is affected.

What it is: CVE-2018-1002104 is a medium-severity vulnerability in Kubernetes k8s.gcr.io/defaultbackend, published on 14 Jan 2020. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2018-1002104 in the wild and no public exploit code.

Affected packages and fixed versions:
- k8s.io/ingress-nginx (Go): affected all versions; fixed in 1.5
- k8s.io/ingress-nginx (Go): affected all versions; fixed in 1.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1002104/ (Markdown: https://insights.sbomify.com/CVE-2018-1002104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1002104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1002104
- OSV: https://osv.dev/vulnerability/CVE-2018-1002104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1002104/
Summaries are generated and may contain mistakes; the official description above is the record.
