# CVE-2018-1002200: Improper Limitation of a Pathname to a Restricted Directory in plexus-archiver

> Attackers can write arbitrary files via directory traversal in archive extraction, potentially leading to code execution or data modification.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** DEBIAN-CVE-2018-1002200, DSA-4227-1, GHSA-hcxq-x77q-3469, MGASA-2019-0005, RHSA-2018:1836, RHSA-2018:1837, SNYK-JAVA-ORGCODEHAUSPLEXUS-31680, UBUNTU-CVE-2018-1002200, USN-4832-1

## What is CVE-2018-1002200?

CVE-2018-1002200 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 25 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

plexus-archiver before 3.6.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in an archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1002200?

2 open source packages ship an affected version, including org.codehaus.plexus:plexus-archiver. It affects 5 products.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.codehaus.plexus:plexus-archiver` | Maven | All versions | 3.6.0 |
| `org.codehaus.plexus:plexus-archiver` | Maven | All versions | 3.6.0 |
| `plexus-archiver` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver-javadoc` | Red Hat:enterprise_linux:7::client | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver-javadoc` | Red Hat:enterprise_linux:7::computenode | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver-javadoc` | Red Hat:enterprise_linux:7::server | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.2-5.el7_5 |
| `plexus-archiver-javadoc` | Red Hat:enterprise_linux:7::workstation | All versions | 0:2.4.2-5.el7_5 |
| `rh-maven33-plexus-archiver` | Red Hat:rhel_software_collections:3::el6 | All versions | 0:2.4.2-5.1.el6 |
| `rh-maven33-plexus-archiver-javadoc` | Red Hat:rhel_software_collections:3::el6 | All versions | 0:2.4.2-5.1.el6 |
| `rh-maven33-plexus-archiver` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:2.4.2-5.1.el7 |
| `rh-maven33-plexus-archiver-javadoc` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:2.4.2-5.1.el7 |
| `rh-maven35-plexus-archiver` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:3.4-4.1.el7 |
| `rh-maven35-plexus-archiver-javadoc` | Red Hat:rhel_software_collections:3::el7 | All versions | 0:3.4-4.1.el7 |

Products: Codehaus-Plexus Plexus-Archiver, Debian Debian Linux, Redhat Enterprise Linux, Redhat Enterprise Linux Desktop, Redhat Enterprise Linux Workstation.

## How do I fix CVE-2018-1002200?

Upgrade org.codehaus.plexus:plexus-archiver to 3.6.0 or later.

## Is CVE-2018-1002200 being exploited?

There is no known exploitation of CVE-2018-1002200 in the wild and no public exploit code.

Public exploit code:

- https://github.com/shoucheng3/codehaus-plexus__plexus-archiver_CVE-2018-1002200_3-5 (github_poc): https://github.com/shoucheng3/codehaus-plexus__plexus-archiver_CVE-2018-1002200_3-5

## Other vulnerabilities in Debian Debian Linux

- [CVE-2023-37460](https://insights.sbomify.com/CVE-2023-37460/): Plexus Archiver vulnerable to Arbitrary File Creation in AbstractUnArchiver (high 8.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1002200 and fix it if it is affected.

What it is: CVE-2018-1002200 is a medium-severity path traversal vulnerability in Debian Debian Linux, published on 25 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1002200 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.codehaus.plexus:plexus-archiver (Maven): affected all versions; fixed in 3.6.0
- org.codehaus.plexus:plexus-archiver (Maven): affected all versions; fixed in 3.6.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1002200/ (Markdown: https://insights.sbomify.com/CVE-2018-1002200/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1002200
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1002200
- OSV: https://osv.dev/vulnerability/CVE-2018-1002200

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1002200/
Summaries are generated and may contain mistakes; the official description above is the record.
