# CVE-2018-1002204: Arbitrary File Write in adm-zip

> Attackers can write arbitrary files via Zip-Slip in adm-zip, potentially leading to code execution or data modification.

- **Severity:** Medium 5.5 (`CVSS:3.1/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2018
- **Updated:** 5 Aug 2024
- **Also known as:** CLSA-2026-1776731784, GHSA-3v6h-hqm4-2rg6

## What is CVE-2018-1002204?

CVE-2018-1002204 is a medium-severity path traversal vulnerability in node.js adm-zip, published on 25 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

adm-zip npm library before 0.4.9 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1002204?

2 open source packages ship an affected version, including adm-zip. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `adm-zip` | npm | All versions | 0.4.11 |
| `adm-zip` | npm | All versions | 0.4.11 |

Products: Adm-Zip Project Adm-Zip.

## How do I fix CVE-2018-1002204?

Upgrade adm-zip to 0.4.11 or later.

## Is CVE-2018-1002204 being exploited?

There is no known exploitation of CVE-2018-1002204 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1002204 and fix it if it is affected.

What it is: CVE-2018-1002204 is a medium-severity path traversal vulnerability in node.js adm-zip, published on 25 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1002204 in the wild and no public exploit code.

Affected packages and fixed versions:
- adm-zip (npm): affected all versions; fixed in 0.4.11
- adm-zip (npm): affected all versions; fixed in 0.4.11

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1002204/ (Markdown: https://insights.sbomify.com/CVE-2018-1002204/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1002204
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1002204
- OSV: https://osv.dev/vulnerability/CVE-2018-1002204

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1002204/
Summaries are generated and may contain mistakes; the official description above is the record.
