# CVE-2018-1002206: Directory Traversal in SharpCompress

> Attackers can write arbitrary files via Zip-Slip in SharpCompress, potentially leading to code execution or data modification.

- **Severity:** Medium 5.5 (`CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 25 Jul 2018
- **Updated:** 17 Sep 2024
- **Also known as:** GHSA-fxh6-w476-hgr4, SNYK-DOTNET-SHARPCOMPRESS-60246

## What is CVE-2018-1002206?

CVE-2018-1002206 is a medium-severity path traversal vulnerability in SharpCompress, published on 25 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

SharpCompress before 0.21.0 is vulnerable to directory traversal, allowing attackers to write to arbitrary files via a ../ (dot dot slash) in a Zip archive entry that is mishandled during extraction. This vulnerability is also known as 'Zip-Slip'.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2018-1002206?

2 open source packages ship an affected version, including SharpCompress. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `SharpCompress` | NuGet | All versions | 0.21.0 |
| `SharpCompress` | NuGet | All versions | 0.21.0 |

Products: Adamhathcock Sharpcompress.

## How do I fix CVE-2018-1002206?

Upgrade SharpCompress to 0.21.0 or later.

## Is CVE-2018-1002206 being exploited?

There is no known exploitation of CVE-2018-1002206 in the wild and no public exploit code.

## Other vulnerabilities in SharpCompress

- [CVE-2026-44788](https://insights.sbomify.com/CVE-2026-44788/): SharpCompress: Directory traversal via directory entries in WriteToDirectory (zip slip variant) (medium 5.9)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-1002206 and fix it if it is affected.

What it is: CVE-2018-1002206 is a medium-severity path traversal vulnerability in SharpCompress, published on 25 Jul 2018. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-1002206 in the wild and no public exploit code.

Affected packages and fixed versions:
- SharpCompress (NuGet): affected all versions; fixed in 0.21.0
- SharpCompress (NuGet): affected all versions; fixed in 0.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-1002206/ (Markdown: https://insights.sbomify.com/CVE-2018-1002206/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-1002206
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-1002206
- OSV: https://osv.dev/vulnerability/CVE-2018-1002206

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-1002206/
Summaries are generated and may contain mistakes; the official description above is the record.
