# CVE-2018-10095: Dolibarr Cross-site scripting (XSS) vulnerability

> Remote attackers can inject arbitrary web script or HTML via the foruserlogin parameter in Dolibarr, potentially leading to session hijacking or malicious actions.

- **Severity:** Medium 6.1 (`CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 22 May 2018
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-p2fm-8rhj-58fr, UBUNTU-CVE-2018-10095

## What is CVE-2018-10095?

CVE-2018-10095 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Cross-site scripting (XSS) vulnerability in Dolibarr before 7.0.2 allows remote attackers to inject arbitrary web script or HTML via the foruserlogin parameter to adherents/cartes/carte.php.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-10095?

2 open source packages ship an affected version, including dolibarr/dolibarr. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `dolibarr/dolibarr` | Packagist | All versions | 7.0.2 |
| `dolibarr/dolibarr` | Packagist | All versions | 7.0.2 |

Products: Dolibarr Dolibarr.

## How do I fix CVE-2018-10095?

Upgrade dolibarr/dolibarr to 7.0.2 or later.

## Is CVE-2018-10095 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-10095 exists.

Public exploit code:

- Dolibarr <7.0.2 - Cross-Site Scripting (nuclei): http/cves/2018/CVE-2018-10095.yaml

## Other vulnerabilities in n/a

- [CVE-2019-19212](https://insights.sbomify.com/CVE-2019-19212/): Dolibarr Cross-site Scripting via the qty parameter in product/fournisseurs.php (critical 9.8)
- [CVE-2018-16809](https://insights.sbomify.com/CVE-2018-16809/): Dolibarr SQL injection via the integer parameters qty and value_unit (critical 9.8)
- [CVE-2018-10094](https://insights.sbomify.com/CVE-2018-10094/): Dolibarr SQL injection vulnerability (critical 9.8)
- [CVE-2018-9019](https://insights.sbomify.com/CVE-2018-9019/): Dolibarr SQL Injection vulnerability (critical 9.8)
- [CVE-2017-14238](https://insights.sbomify.com/CVE-2017-14238/): Dolibarr SQL injection vulnerability in admin/menus/edit.php (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10095 and fix it if it is affected.

What it is: CVE-2018-10095 is a medium-severity cross-site scripting vulnerability in n/a, published on 22 May 2018. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2018-10095 exists.

Affected packages and fixed versions:
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 7.0.2
- dolibarr/dolibarr (Packagist): affected all versions; fixed in 7.0.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10095/ (Markdown: https://insights.sbomify.com/CVE-2018-10095/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10095
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10095
- OSV: https://osv.dev/vulnerability/CVE-2018-10095

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10095/
Summaries are generated and may contain mistakes; the official description above is the record.
