{"answers":{"affected":"It affects 1 product.","exploited":"There is no known exploitation of CVE-2018-10113 in the wild and no public exploit code.","fix":"Apply the vendor's patch.","what":"CVE-2018-10113 is a high-severity denial of service vulnerability in n/a, published on 14 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2018-10113 and fix it if it is affected.\n\nWhat it is: CVE-2018-10113 is a high-severity denial of service vulnerability in n/a, published on 14 Apr 2018. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2018-10113 in the wild and no public exploit code.\n\nAffected product: n/a. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2018-10113/ (Markdown: https://insights.sbomify.com/CVE-2018-10113/index.md)","id":"CVE-2018-10113","markdown":"https://insights.sbomify.com/CVE-2018-10113/index.md","name":"CVE-2018-10113","record":{"aliases":["DEBIAN-CVE-2018-10113","GHSA-732f-45j6-wqx9","SUSE-SU-2020:1658-1","UBUNTU-CVE-2018-10113"],"analysis":{"component_type":"library","fix_type":"patch","impacts":["denial_of_service"],"network_reachable":"yes","non_default_config":false,"product_category":"GEGL image library","requires_auth":"none","summary":"An attacker can cause a denial of service via unbounded memory allocation in the GEGL library's PPM loader, crashing the application.","user_interaction":"not_required","vuln_class":"denial_of_service"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"mitre","cpe":[{"product":"generic_graphics_library","vendor":"gegl"}],"cvss":{"score":7.5,"severity":"high","source":"nvd","vector":"CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H","version":"3.0"},"cwes":[{"id":"CWE-119","name":"Improper Restriction of Operations within the Bounds of a Memory Buffer"}],"description":"An issue was discovered in GEGL through 0.3.32. The process function in operations/external/ppm-load.c has unbounded memory allocation, leading to a denial of service (application crash) upon allocation failure.","ecosystems":["SUSE:Linux Enterprise Software Development Kit 12 SP4","SUSE:Linux Enterprise Software Development Kit 12 SP5","SUSE:Linux Enterprise Workstation Extension 12 SP4","SUSE:Linux Enterprise Workstation Extension 12 SP5"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Denial of service in n/a","id":"CVE-2018-10113","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"denial_of_service","year":"2018"},"n_packages":4,"n_references":1,"next":{"headline":"Memory corruption in n/a","id":"CVE-2018-10114"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP4","fixed":["0.2.0-15.3.99"],"introduced":["0"],"last_affected":[],"package":"gegl","purl":"pkg:rpm/suse/gegl\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP4","source":"SUSE-SU-2020:1658-1"},{"ecosystem":"SUSE:Linux Enterprise Software Development Kit 12 SP5","fixed":["0.2.0-15.3.99"],"introduced":["0"],"last_affected":[],"package":"gegl","purl":"pkg:rpm/suse/gegl\u0026distro=SUSE%20Linux%20Enterprise%20Software%20Development%20Kit%2012%20SP5","source":"SUSE-SU-2020:1658-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP4","fixed":["0.2.0-15.3.99"],"introduced":["0"],"last_affected":[],"package":"gegl","purl":"pkg:rpm/suse/gegl\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP4","source":"SUSE-SU-2020:1658-1"},{"ecosystem":"SUSE:Linux Enterprise Workstation Extension 12 SP5","fixed":["0.2.0-15.3.99"],"introduced":["0"],"last_affected":[],"package":"gegl","purl":"pkg:rpm/suse/gegl\u0026distro=SUSE%20Linux%20Enterprise%20Workstation%20Extension%2012%20SP5","source":"SUSE-SU-2020:1658-1"}],"prev":{"headline":"Memory corruption in n/a","id":"CVE-2018-10112"},"products":["n/a"],"published":"2018-04-14","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":null,"exploitation":null,"technical_impact":null},"state":"PUBLISHED","updated":"2024-08-05","vendors":["n/a"]},"summary":"An attacker can cause a denial of service via unbounded memory allocation in the GEGL library's PPM loader, crashing the application.","url":"https://insights.sbomify.com/CVE-2018-10113/"}