CVE-2018-10125 Cross-site Scripting in Contao
Cross-site scripting vulnerability in Contao CMS system log allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- A user has to click or open something
- Fix
- Available
What is CVE-2018-10125?
CVE-2018-10125 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Official description
Contao before 4.5.7 has XSS in the system log.
Weakness: CWE-79
Which versions are affected by CVE-2018-10125?
12 open source packages ship an affected version, including contao/core-bundle, contao/contao and contao/core. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
contao/core-bundle Packagist | From 3.0.0 | 3.5.35 |
contao/core-bundle Packagist | From 3.0.0 | 3.5.35 |
contao/core-bundle Packagist | From 4.0.0 | 4.4.18 |
contao/core-bundle Packagist | From 4.0.0 | 4.4.18 |
contao/core-bundle Packagist | From 4.5.0 | 4.5.8 |
contao/core-bundle Packagist | From 4.5.0 | 4.5.8 |
6 more packages
contao/contao Packagist | From 4.0.0 | 4.4.18 |
contao/contao Packagist | From 4.0.0 | 4.4.18 |
contao/contao Packagist | From 4.5.0 | 4.5.8 |
contao/contao Packagist | From 4.5.0 | 4.5.8 |
contao/core Packagist | From 3.0.0 | 3.5.35 |
contao/core Packagist | From 3.0.0 | 3.5.35 |
Products include Contao Contao.
How do I fix CVE-2018-10125?
Upgrade contao/core-bundle to a fixed version for your release line: 3.5.35, 4.4.18 or 4.5.8.
Escape output for the context it lands in and set a strict Content Security Policy. Upgrading the affected component is the real fix. More about Cross-site scripting.
Is CVE-2018-10125 being exploited?
There is no known exploitation of CVE-2018-10125 in the wild and no public exploit code.
Other vulnerabilities in n/a
- CVE-2022-26265 Remote Code Execution in Contao Managed Edition
- CVE-2019-11512 Contao SQL injection in the file manager
- CVE-2012-4383 Contao core SQL Injection Vulnerability
- CVE-2019-19745 Unrestricted file uploads in Contao
- CVE-2024-28235 Contao possible cookie sharing with external domains while checking protected pages for broken links
Sources
Also known as GHSA-pj4j-287j-f742.