# CVE-2018-10125: Cross-site Scripting in Contao

> Cross-site scripting vulnerability in Contao CMS system log allows attackers to inject malicious scripts, potentially leading to session hijacking or code execution.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 16 Mar 2020
- **Updated:** 5 Aug 2024
- **Also known as:** GHSA-pj4j-287j-f742

## What is CVE-2018-10125?

CVE-2018-10125 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Contao before 4.5.7 has XSS in the system log.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2018-10125?

12 open source packages ship an affected version, including contao/core-bundle, contao/contao and contao/core. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/core-bundle` | Packagist | From 3.0.0 | 3.5.35 |
| `contao/core-bundle` | Packagist | From 3.0.0 | 3.5.35 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.18 |
| `contao/core-bundle` | Packagist | From 4.0.0 | 4.4.18 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.5.8 |
| `contao/core-bundle` | Packagist | From 4.5.0 | 4.5.8 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.18 |
| `contao/contao` | Packagist | From 4.0.0 | 4.4.18 |
| `contao/contao` | Packagist | From 4.5.0 | 4.5.8 |
| `contao/contao` | Packagist | From 4.5.0 | 4.5.8 |
| `contao/core` | Packagist | From 3.0.0 | 3.5.35 |
| `contao/core` | Packagist | From 3.0.0 | 3.5.35 |

Products: Contao Contao.

## How do I fix CVE-2018-10125?

Upgrade contao/core-bundle to a fixed version for your release line: 3.5.35, 4.4.18 or 4.5.8.

## Is CVE-2018-10125 being exploited?

There is no known exploitation of CVE-2018-10125 in the wild and no public exploit code.

## Other vulnerabilities in n/a

- [CVE-2022-26265](https://insights.sbomify.com/CVE-2022-26265/): Remote Code Execution in Contao Managed Edition (critical 9.8)
- [CVE-2019-11512](https://insights.sbomify.com/CVE-2019-11512/): Contao SQL injection in the file manager (critical 9.8)
- [CVE-2012-4383](https://insights.sbomify.com/CVE-2012-4383/): Contao core SQL Injection Vulnerability (high 8.8)
- [CVE-2019-19745](https://insights.sbomify.com/CVE-2019-19745/): Unrestricted file uploads in Contao (high 8.8)
- [CVE-2024-28235](https://insights.sbomify.com/CVE-2024-28235/): Contao possible cookie sharing with external domains while checking protected pages for broken links (high 8.4)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2018-10125 and fix it if it is affected.

What it is: CVE-2018-10125 is a medium-severity cross-site scripting vulnerability in n/a, published on 16 Mar 2020. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2018-10125 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/core-bundle (Packagist): affected from 3.0.0; fixed in 3.5.35
- contao/core-bundle (Packagist): affected from 3.0.0; fixed in 3.5.35
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.18
- contao/core-bundle (Packagist): affected from 4.0.0; fixed in 4.4.18
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.5.8
- contao/core-bundle (Packagist): affected from 4.5.0; fixed in 4.5.8
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.18
- contao/contao (Packagist): affected from 4.0.0; fixed in 4.4.18
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.5.8
- contao/contao (Packagist): affected from 4.5.0; fixed in 4.5.8
- contao/core (Packagist): affected from 3.0.0; fixed in 3.5.35
- contao/core (Packagist): affected from 3.0.0; fixed in 3.5.35

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2018-10125/ (Markdown: https://insights.sbomify.com/CVE-2018-10125/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2018-10125
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2018-10125
- OSV: https://osv.dev/vulnerability/CVE-2018-10125

---
From sbomify Insights: https://insights.sbomify.com/CVE-2018-10125/
Summaries are generated and may contain mistakes; the official description above is the record.
